STORM Drone 6 GPS Flying Platform

Discussion in 'Product Reviews' started by harena, Dec 1, 2013.

  1. mdr75

    mdr75 Member

    Hi.
    It seems as though it's not getting enough power to lift it. It'll lift 3 or 4 feet off the ground but won't go any higher and gradually comes back down.
    There's no gimbal installed, only a small fpv camera and batteries are full so it's reasonably light.
    It's set to intelligent so cuts off after arming if it isn't increased to over 10%.
    When i give it some elev, nothing happens until it goes over 50% but i don't notice any change in motor speed if i then go to 100%. It's as if something is restricting it.
    Motor test done in Tarot assistant shows they're fine.
    Wondering if there's more of an underlying issue with the esc's or motors?
    Tarot zyx-m system is new and pmu, fc etc seems fine.
    Am i missing a setting somewhere that's restricting juice to the motors or a setting in my Devo 7 controller?
    Thanks in advance for any advice.
     
  2. Jackson

    Jackson USA member at large

    :)
     
  3. RENOV8R

    RENOV8R Well-Known Member

    Have you done stick calibration in the assistant software?
     
    mdr75 likes this.
  4. mdr75

    mdr75 Member

    Yep. Well... I've done it now but it's a bit late to try it outside.
    I'll try it again in the morning.
    I've also changed some settings in the transmitter that would have been in place when it was sold as a package.
    I appreciate your help guys cheers.
     
  5. RENOV8R

    RENOV8R Well-Known Member

    If you're still having problems, go through this video. Sometimes it's just one simple thing we forget to do that makes all the difference.
     
  6. mdr75

    mdr75 Member

    That's brilliant thank you I'll watch that now.
    Think the settings got that mucked up in the devo7 that I reset them all this morning and set them up as per Helipal when they ship them with the Storm Drone 6.
    It all seemed ok, took off quick and was goin up very quick so pulled back on the throttle to bring it under control, it started hovering and then dropping!!
    I gave it more throttle to 100% but it just kept dropping until it bounced to a landing. It seems as though as soon as I hold back on the throttle the power dies and never returns with throttle.
    I'll watch the vid and see if that sheds any light.
    Thanks again.
     
  7. mdr75

    mdr75 Member

    Completely lost all patience with it now.
    Nothing i try works. Followed a ton of tutorials, calibrations, resets, throttle curves etc etc etc..
    Think i'll give in to the inevitable and break it down to sell.
    It's been a great learning curve for building one ( over and over again!) but i think i'll stick to my other RTF ones.
    Think it must be an issue with the fc itself so may try and send it back for them to look at.
    Thanks very much for your help guys.
     
  8. RENOV8R

    RENOV8R Well-Known Member

    Are you in GPS or ATT mode when this is happening? If you're in GPS mode in close proximity (I believe it's 5 metres with the ZYX-M) and it drops below 5 satellites, it'll go into failsafe and just land like you've described.
     
  9. mdr75

    mdr75 Member

    Just a quick update incase anybody is interested.
    I've removed the Tarot system and reinstalled the Naza Lite unit that came with it.
    Seems much more stable and it reacts better to throttle.
    One problem I have now is with the devo 7 transmitter. The switches don't operate the ioc or gps/atti functions correctly.
    One good thing about the Tarot was the channel mapping function in Tarot Assistant.
    I've done a reset of the devo 7 and followed the Helipal instructions for settings they recommend on their website but they still don't work right.
    Can anybody please point me in the direction of a full devo 7 for Storm Drone 6 settings page if such a thing exists?
    I'm on the verge of ditching it altogether but on the other hand don't want it to beat me.
    Once again i really do appreciate your help.
    Cheers.
     
  10. gold drones

    gold drones New Member

    yes I have one my channel features it
     
  11. beoir.sicnarf

    beoir.sicnarf Member

    I was just gifted a storm drone 6, but there seen to be a few issues. Most notably, the gimbal. The previous owner said he couldn't get it to work "quite right". It came with the storm sd-8 gimbal. When I power on the drone, the gimbal doesn't adjust to horizonal. It just sits there. Does it have to be connected to a camera to do this?

    Which leads me into my next issue. I can't afford a GoPro, so I bought an aseko ek7000. It's a great camera, but it uses a micro USB connection and GoPros use a mini USB. So I'm thinking if I chop off the mini and and solder on a micro, that might get it to work.

    Thoughts on the gimbal though?
     
  12. beoir.sicnarf

    beoir.sicnarf Member

    Ugh. Tried to upload some pics of the gimbal, but they're too large. I'll have to resize then when I get home.
     
  13. Jackson

    Jackson USA member at large

    Many will say it's best to have a camera on the gimbal, getting it properly balanced as a first step. You will sometimes see folks adding weights to compensate for different non-standard cameras.
    Is the gimbal in fact connected to the power source When you power up your quad do you see an indicater light up on the gimbal??
     
  14. beoir.sicnarf

    beoir.sicnarf Member

    Yes, there are LEDs lit up. I'll try to get pics of all the connections. Maybe a half hour or so.
    Edit: the camera is a hero 4 knock off. But it has the exact same weight and dimensions.
     
  15. beoir.sicnarf

    beoir.sicnarf Member

    OK took a quick video.
     
  16. beoir.sicnarf

    beoir.sicnarf Member

  17. Jackson

    Jackson USA member at large

    All the gimbal needs is power from the battery for it to initialize, nothing else needs to be plugged in/wired. That it doesn't initialize needs to be solved before moving on.
     
  18. beoir.sicnarf

    beoir.sicnarf Member

    So where do I go from here? It has power, and it doesn't work, so I'm guessing the gimbal is junk?
     
  19. beoir.sicnarf

    beoir.sicnarf Member

    Here's the response from helipal:
    GoPro camera must installed before supplying power to the Gimbal. Failure to do so will result in damage to the Gimbal motors.
    Please check the wires connection whether correct, thanks.

    I forgot to tell them it's for a sd-8 gimbal.
     

    Attached Files:

  20. beoir.sicnarf

    beoir.sicnarf Member

    So possibly, I need to figure out this camera hook up thing first if a connected camera is necessary to activate the gimbal...
     

Share This Page