STORM Drone 6 GPS Flying Platform

Discussion in 'Product Reviews' started by harena, Dec 1, 2013.

  1. Nate H

    Nate H Active Member

  2. Nate H

    Nate H Active Member

    Also, have you ever calibrated the compass before? It's an awkward process with the Storm Drone. You need to adjust the transmitter gear channel travel so that the tri-position switch on the right shoulder of the tx activates the Manual setting in the NAZA flight modes. By default helipal has it turned off. I think they have a video on how to do this.
     
  3. I have downloaded the calibration assistant for the Mac but have not attempted to run it yet. I tried resetting the gear and flap settings as per Helipad's recommendation and toggled FMD switch on and off several times. It's still did not solve the
    problem
     
  4. Nate H

    Nate H Active Member

    You really need to check the settings inside the NAZA assistant, because even if the switch travel is setup correctly, the flight mode inside the NAZA could be set to something other than Manual. Basically, the "Manual" rectangle at the bottom of the RC tab should be highlighted when the FMD switch is in the position nearest to you. See Fig. 1 attachment. Furthermore, the middle and leftmost rectangle should light up blue when the FMD switch is set to the ATTI and GPS modes respectively.

    The method for flipping the FMD switch for compass calibration was also a sticking point for me initially. Basically, you just switch it back and forth a dozen times or so, ending back on GPS mode, and then wait for the LED to turn yellow. When I was using the Lite firmware, it usually took about 10-11 repetitions and a 1 second pause. It would not enter calibration mode unless I paused after rocking the switch 10-11 times. With the NAZA V2 software, it seems to enter the calibration mode after 5-6 repetitions and without needing to pause afterwards.
     

    Attached Files:

  5. when I plug the drone into the computer I get a con fig error message. Any idea about that. It may be because I don't know how to reset my transmitter into the NAZA mode. It seems to only have Mod 1 thru 15 as options. Any suggestions?
     
  6. Nate H

    Nate H Active Member

    Ok, let's start at square one. Are you able to open the NAZA Asssistant software? Which version NAZA do you have and what firmware (did you do the lite to v2 trick)? What NAZA assistant program are you running - orange icon or red icon?
     
  7. orange icon... supposedly v2 for mac
     
  8. Nate H

    Nate H Active Member

    Do you have the red NAZA Lite on the drone or the Orange NAZA v2?
     
  9. Nate H

    Nate H Active Member

    So you plug in the USB cable, connect the battery to the drone, open the software and then get an error? Screen shot?
     
  10. That's correct but I'm not at the computer now. I'll send a screen shot later. A window pops ip and says con- fig error when I connect the drone A small caution triangle is also on the lower left. And it is "stuck"in Atti mode tab
     
  11. Nate H

    Nate H Active Member

    From the DJI website:

    How to deal with the configuration error?
    Please calibrate your transmitter sticks and then restart MC.

    This is done in the Basic Tab under "RC."

    See if it is still stuck after performing a stick calibration on the NAZA software, and for good measure, with the DEVO 7 TX as well.
     
  12. MTKray

    MTKray New Member

    Hi all I've learned a lot from this thread and I'm new to the SD6 but I'm having a problem. GPS and everything works great, but when I bring it in to land, I land it, kill the throttle and then it revs up with a boost of speed causing it to turn or flip. This makes landing near impossible and I'm hoping that there is a way to change this.
     
  13. Nate H

    Nate H Active Member

    A couple things you might try:

    - an IMU calibration inside the NAZA software

    - a command sticks calibration in the NAZA software

    - what is your cutoff set to? Immediate or Intelligent?

    - NAZA Lite or V2? V2 has a assisted takeoff feature that could be an issue

    - Maybe an ESC calibration. Helipal has a video I think.
     
  14. MTKray

    MTKray New Member

    Thanks, these are all good things to try but I think I know what's wrong... Tell me what you think. I was watching the start up video on helipal and the guy set the gear to 82.5. I blindly followed the instructions before I flew but I have only taken it up for test flights. I didnt put the gimbal, FPV, or camera on it, plus the battery I used was the 2500 so I'm guessing that the done needs to be calibrated for less weight, OR put more weight on. Is this a possibility?
     
  15. Nate H

    Nate H Active Member

    The gear setting allows the NAZA to enter Manual mode (switch towards you). You should be flying with the FMD switch fully back for GPS. Your motor idle could be too high for a naked craft, and you could try setting your motor idle speed to a lesser value in the NAZA software, but it sounds like a gyro/accelerometer or software problem to me. If your stick is at zero after landing and you kill the motors with CSC, it DEFINITELY shouldn't start up again unless you're bringing the stick back up after the motors stop - no matter what your idle speed is set to.

    Are all the trim settings at zero on your TX?
     
  16. MTKray

    MTKray New Member

    Yeah the problem was that I wasn't cutting the power with CSC. It works great now except now something funny happened today. I took it out in about 20ยบ weather and was flying it around and a couple times it jittered almost as if the ESC's were cutting in and out. It only happened twice so I didn't think much of it, but then I changed the battery and flew it up about 50ft. and lost connection. Thankfully it executed auto return, but it was a little unnerving that the connection lost so close to me. Could it be that the cold was causing the NAZA or ESC's to short out? I'm pretty sure my firmware is up-to-date seeing as I just got it, but after hearing about the NAZA flip of death I'm a little concerned.
     
  17. Nothing worked but thanks for your ideas. I sent it back to Helipad for repairs. Lets see what they say.
     
  18. mdr75

    mdr75 Member

    Hi. Is anybody still watching this thread?
    I have a Storm Drone 6 with Tarot zyx-m installed that i have an issue with.
    Cheers.
     
  19. RENOV8R

    RENOV8R Well-Known Member

    Hi, what's the issue?
     

Share This Page