FlySky FS-i6 wont work after CleanFlight firmware update

Discussion in 'Parts & Components' started by BL Swagger, Dec 7, 2017.

  1. BL Swagger

    BL Swagger Well-Known Member

    I had quite the ordeal figuring out how to update the firmware of my SPF3 FC . Turns out the issue was a faulty mini USB cable the whole time.

    Before updating the firmware, my quad would arm and run just fine. I needed to calibrate everything using CleanFlight, which resulted in updating the firmware.

    I'm using CleanFlight 2.1.0

    I flashed firmware to the F3 flight controller, and after that, the FlySky doesn't seem to work anymore. I bind the transmitter and receiver again. I can confirm with "RX" symbol in the corner of my transmitter display.

    When I try to arm the quad, nothing... when I try to read values under the "receiver" tab on CleanFlight, I get nothing... and yes, I have the battery plugged in.

    It seems the transmitter is not binding with the receiver correctly since I'm reading no values on Cleanflight.. but then again, I can see the RX on my transmitter display.

    Regretfully, I did not save the state that the FC was in before flashing new firmware.

    Any clues of where I could have gone wrong? And how to fix this?
  2. BL Swagger

    BL Swagger Well-Known Member

    Update: Not sure if I fixed the issue. I thought the FS-i6 would use a PPM receiver mode. I was not getting a response from that. I changed it to PWM (one-wire per channel) and now it will arm and give me readings on Betaflight. (correction from before, I am using betaflight).

    However, only 3 of my motors activate when I increase the throttle stick. Takes a lot for the 4th motor to spin. Obviously, this is not working correctly but its progress.
  3. mozquito1

    mozquito1 Well-Known Member

    Very same happened to me about a year ago. The port for motor 4 was kuput.
    Had to throw it away. A knock can do that to boards especially naze32.
    You should try a full reset of the board on the first tab, setup. You would be surprised what a reset can do.
    Just start the setup again. Don't reload your old settings.
  4. Jackson

    Jackson USA member at large

    Which RX are you using?
  5. mozquito1

    mozquito1 Well-Known Member

    We know it comes with ia6b which is ppm/ibus. Reflow the solder joints to make sure. Is ppm on in Tx menu & have you setup arm & mode switches.
    I use ibus on uart3 if I had a busted USB I would have to use an ftdi chip on uart 2.
    Then turn both on in the ports tab.
  6. Jackson

    Jackson USA member at large

    No we don't. Many often get the package that comes with the FS-ia6. I did.
    Which is PWM only.
    BL Swagger likes this.
  7. BL Swagger

    BL Swagger Well-Known Member

    Yes, I received this FS-IA6 receiver. And the PWM is the correct mode. I know that now. But I am having issues getting all the motors on the same track, and sometimes arming the quad is not working. I am trying out new firmware at this point. If the quad does arm, then the motors don't respond in unison.

    My main point is that it worked well before flashing new FC firmware. It was a brand new quad I just built and I needed to flash new FC firmware in order to utilize Cleanflight or Betaflight so I could calibrate for a smoother flight. Now it seems I messed up something with my transmitter/receiver....

    I cant wrap my head around why the quad doesn't do something like arm, when the transmitter clearly shows it is bound with the quad due to the RX in the corner display. And also, the quad responds perfectly to master control on Cleanflight.

    Ill keep double checking my configuration settings. But does anyone know of a SPF3 FC firmware version that they know works and is reliable?
  8. Badfish

    Badfish JA.O.A.T.

    I don't see any mention of ESC calibration. That has fixed my motor timing issues.
    BL Swagger likes this.
  9. Jackson

    Jackson USA member at large

    You could try ESC calibration like this.

    BL Swagger likes this.
  10. BL Swagger

    BL Swagger Well-Known Member

    Ahhhhh... very true. I assumed because it worked well on initial set up that I wouldn't have to do that. That could explain the weird response I was getting before. I'll start over, and remember the ESC this time.
  11. BL Swagger

    BL Swagger Well-Known Member

    After ESC calibration, the quad seems to be working great. Thanks guys!

    Now on to the VTX
    Badfish likes this.
  12. Badfish

    Badfish JA.O.A.T.

    Haha! The blind squirrel finds a nut.
    Glad it wasn't an Rx issue. I am waiting for one like yours to show up soon.
  13. mozquito1

    mozquito1 Well-Known Member

    My bad, I can't remember the last time I used one of those. I did get one with my Tx but I quickly got the ia6b. & ia6c.
    I tried to de-pin it to streamline it to compensate for its size. & direct solder. But i must have fried somthing. That was the last I seen but you can buy em with ia6b and ia6c.. When I build a quad for a random I agree they buy there Tx preferably with an rx ibus or sbus capability, & I source the other parts.
    I'm assuming as these ppl give me an ia6b rx, there may be an option. No one has moaned about a wasted rx. I did see an fsi6 & ia6c posted as brand new on eBay about springtime.
  14. Badfish

    Badfish JA.O.A.T.

    sonovabitch! this thing is already giving me hell
  15. BL Swagger

    BL Swagger Well-Known Member

    To avoid posting a new thread, I am going to attempt to continue on this thread considering it is the same build and a similar issue.

    First video shows the control of the motors using the Master Control on CleanFlight. The motors rev up in sync.

    The second video shows the control of the motors using the FS-i6 Radio Transmitter. The motors are out of sync. Motors 1 & 4 are noticeably off. Motor 4 will eventually respond if enough throttle is applied but still lags behind.

    I have already checked many components. I have switched out the 4in1 20amp ESC. I have moved the motors around. I have checked all my connections. I have even resoldered many components, mainly because I was swapping parts. I have calibrated the ESCs over and over again. I still receive the same results as shown in the videos.

    Going forward, I will try flashing new firmware on the SPF3 FC and configure the settings from scratch.

    Components & Settings I'm using:
    I'm using a FS-iA6 receiver and FlySky transmitter. So PWM input.
    4in1 20amp ESC using Oneshot125 for motor protocol.
    SPF3 FC running CleanFlight. (I can switch to Betaflight too if needed)

    Does anyone have an idea of what is going on? And a solution to fix it?

    I'm hoping its not a flawed FC, but I have a spare if I need to swap.
  16. mozquito1

    mozquito1 Well-Known Member

    Put some props on it & then see how it reacts. This is normal, it's fighting itself coz no props.
  17. BL Swagger

    BL Swagger Well-Known Member

    The quad flipped when I had props on.

    I think I may have damaged the 1 & 4 pins on the FC that connect to the ESCs.


    The soldering was a bit sloppy, and this FC has been rewired a few times.
  18. BL Swagger

    BL Swagger Well-Known Member

    Update: It lifts off! The balance is terrible but glad to see I have working components... I think lol
    mozquito1 likes this.
  19. mozquito1

    mozquito1 Well-Known Member

    If the motors moved a bit then they are OK, for connectivity anyway.
    My very first board I fried 2 motor pins.
    They didn't move a muscle.
    Try a full board reset on the setup tab. Then try again with props. All on correct way. Assuming all the wiring is correct,
    Is the board orientation correct. Is it moving as it should in setup tab.
    Mine was but RENOV8R on here said try it & it sorted my problem.
  20. mozquito1

    mozquito1 Well-Known Member

    What was it then.
    Are you still on chrome betaflight/cleanflight. Or the standalone off github.
    My hat is off to you. I know what it takes from building to setting all the drivers up & setting things up. I'm still learning myself, so congrats.
    Now fly it like you stole it.

Share This Page