DJI Naza Lite upgrade help?

Discussion in 'Experimentation' started by DuaneM, Mar 12, 2017.

  1. DuaneM

    DuaneM Drone? I don't see any drone ... crap!

    Hello all, I have been trying to do that old update for Naza Lite to Naza V2 and I keep coming up with this error message (see below). I have tried about 23 different fixes to get rid of that problem inside the Windows program.

    I think I came into the game too late and the fix was put in by DJI. When I downloaded the drivers to run the "Assistant," I think the fix was already in the drivers download file.

    I'm wondering if anyone has the original drivers and original "Assistant" from back in 2012 or early 2013 before the "fix" was thrown out into the internet. The drivers I have now are titled "DJI_WIN_Driver_Installer.exe" or .zip, I have both. I need the early "Assistant" software too.

    The older files have to have been downloaded before 5/28/13.

    I have tried the upgrade several times on several computers (one with Vista) and I have only one more computer I can try this out on, I want to get it right the first time.

    After all the stuff I have bought for my quad, I just can't afford to buy the $300.00 software from DJI. I know about copyright infringements, but I just don't care right now.

    Please don't point me toward the DJI software download page or the Upgrade website, I have been to both many many times. The "Forum" used to talking about this upgrade has been hijacked by DJI or they bought the website and have the "fix" in the upgrade itself now.

    Can you help me? I'll give you my email address in a private conversation.

    Attached Files:

    Last edited: Mar 12, 2017
  2. DuaneM

    DuaneM Drone? I don't see any drone ... crap!

    OR ... does anyone have an upgraded Naza Lite to V2 for sale or trade for my normal working Naza Lite?
  3. ringolong

    ringolong Well-Known Member

    Does the assistant software work correctly, and are you sure you installed the drivers?
  4. DuaneM

    DuaneM Drone? I don't see any drone ... crap!

    I installed the drivers they have at their download page: "DJI_WIN_Driver_Installer.exe"

    The assistant works exactly as it should when I plug in the Lite. This other stuff only happens when I try to do the V2 upgrade. I have even done the F1 and F2 jumper to get back to original firmware several times even though it has never upgraded to the V2.
  5. ringolong

    ringolong Well-Known Member

    Do you have a win7 machine, or know someone that does to use? I have used win8, and win7 with success.

    I don't mind flashing it for you if you pay the shipping.
  6. RENOV8R

    RENOV8R Well-Known Member

    From everything I've ever read, you can't flash the V2 firmware onto the Lite as it doesn't have the V2 CAN bus interface IC and controller
  7. ringolong

    ringolong Well-Known Member

    You can with a specific version. I have flashed every single lite I have ever owned with the v2 firmware.
  8. DuaneM

    DuaneM Drone? I don't see any drone ... crap!

    I have used a Win10, Win7, Vista, and an XP (I hate throwing things away) with no luck and it ALWAYS does the Runtime Error on every machine.

    I swear it's something in the DJI windows drivers, although I found a guy that had the very first DJI drivers. I have yet another XP machine I was going to try those out on.

    Ringolong ... I would do that, but I never got the Naze32 Full Rev6 to work right (it's why I bought the NAZA) and I can't be without my new quad for more than a few hours! I swear I'll go through withdrawals and ending up talking to myself in a corner. When I get another NAZA Lite, I do want to take you up on this offer!

Share This Page