Cant get reciever and FC to talk!

Discussion in 'Getting Started' started by MrkThMn, Jan 7, 2017.

  1. MrkThMn

    MrkThMn Member

    I have a problem that I am really hoping someone here can help me with.

    What I Have and What Works
    For Christmas, I got a Taranis X9D Plus and it came with a X8R receiver. The quad I’m trying to connect it to has an SP Racing F3 FC. I followed the steps to bind the receiver and the Taranis, and I believe I was successful. I get the green light on the receiver when they’re both powered on and when I turn one of them off either my Taranis tells me in it’s sexy Amber voice that it lost the signal or the receiver gives me a red light saying it lost the Taranis. On the quad side of things, I was able to hook it into CleanFlight and I verified it does have the latest version of Betaflight on it. When I pick it up and move it around the 3D model on the “Setup” tab matches it and I can use the “Motors” tab to spin up the motors correctly which means the quad is definitely talking to CleanFlight.

    What Doesnt Work
    SO! Everything seems to be working EXCEPT – I have yet to get the receiver and the FC to talk to each other!!! I cannot get the quad to react to any input from the Taranis. When I have the quad hooked up to CleanFlight I go to the “Receiver” tab to test the controls and get no feedback when moving the sticks around. I move the sticks, nothing happens on the screen. I have tried using PPM and SBUS slots on the X8R and I have adjusted the settings in CleanFlight for Receiver Mode, Serial Receiver Provider, and even tried toggling the Serial RX. None of changes got me connected. Am I missing something or do I have a lemon? I keep wondering if this has something to do with it wanting to be armed but I probably don’t have the right setting so the quad is refusing to initiate. But then again, I should still be able to work with the receiver in Cleanflight whether its armed or not though, right?

    I have worked on this for probably about 15 hours so far (I really wish I was kidding) so I beg for any help you guys can offer! THANK YOU!!
     
  2. Jackson

    Jackson USA member at large

    So basically it works like this?


    Maye some help here, Flip ahead to ~ 13:30, that's when he covers SBus.

     
  3. MrkThMn

    MrkThMn Member

    Thanks so much for your thoughts on this! This first video is actually the video I used to learn the binding process, so you nailed it on the head. It happens exactly like this!

    After making sure I had the X8R plugged into the sbus port I turned it all back on and made sure I still a connection between the Taranis and the receiver. Check!

    I then plugged the quad into CleanFlight, moved the quad around to make sure the 3-D model moved, and it did. I followed the steps in the second video, saving and rebooting as necessary, and even used CLeanFlight to power on the motors just to drive home to myself that the quad was talking to the program. I then went to the receiver section and started moving the sticks and flipping switches. Nothing. The bar graph didn't react to any movements on the Taranis.

    At this point I think I have a broken part somewhere but I'm not sure where. The quad talks to the computer, why not the receiver? The receiver talks to the Taranis, why not the quad?
     
  4. Jackson

    Jackson USA member at large

    That's where a cheap servo, like in the first vid, would help in troubleshooting. It would establish that the RX, is in fact outputting properly.
     
  5. qball

    qball Member

    have you tried flashing it again to betaflight, from the sound of It might not do anything but its worth a try before you start shelling out cash on new parts. it might be a bad download or a bad install.
     
  6. MrkThMn

    MrkThMn Member

    Good idea on this! It's actually something that I hadnt tried yet. Unfortunately after completely wiping and flashing it to the latest firmware I wasnt able to get any improvement. :( I tried both PPM and SBUS but it reacted the same as before.

    I think this is going to be the nail in the coffin for me. The equipment is all brand new so if I can get it to move a servo I'm gonna send it back.

    Thanks again guys for your suggestions!
     
  7. MrkThMn

    MrkThMn Member

    Just wanted to update you guys. I was able to get the quad running tonight thanks to a comment on a YouTube I posted. The person suggested that I change where I had the wire harness plugged in on the FC for that ran to my receiver. It came already plugged in to the one and from all the material I had read/watched it sounded like the correct port but I switched it anyway and that was it! I plugged in back into clean flight, reprogrammed it and was able to get it to work! Who would have thought...

    Should I delete this post now that I have my answer or should I leave it up so others (with maybe the same problem) can read it? I can do a video or even post some pictures here if that would be of more value.
     

Share This Page