When the Gods Frown On You

Discussion in 'General Discussion' started by GlassKnees, Mar 13, 2018.

  1. GlassKnees

    GlassKnees Well-Known Member

    I seriously don't know what I did to perturb the cosmos, but it must have been something serious... I took my two quads out for test flights - my Tarot Sport, to do a video shoot to test out everything - landing gear retract, adjustment to the gimbal (to get the horizon level), and endurance; the Elev-8 with its new FPV setup..

    First, was the Tarot - I could not arm the motors and it seemed as the receiver was not communicating with my transmitter - no camera tilt, no landing gear retract and the little orange LED on the receiver was not lit, which indicates it's connected to the transmitter.

    So, I tried the Elev-8. When I turned on my video monitor, it automatically shut off after about 10 sec. I did manage to fly it, but without the fpv experience..

    After taking both aircraft home and doing some troubleshooting, I discovered that the monitor didn't like the SD card I had inserted in it. So I took one out of my GoPro and the monitor accepted it. I then put the other SD card in my GoPro and the camera was fine with it - I guess the GoPro is less discriminating - who knows?

    The Tarot was another problem... I went through the bind process and got the receiver to connect to the transmitter, but while redoing the radio configuration in Mission Planner (both aircraft have APM 2.6 flight controllers), I was able to set the limits of all the sticks, but not the three position flight modes switch - its as if there is no signal coming from the modes port (#5)... That is probably why I could not arm the motors. I checked the switch settings on the transmitter and I'm convinced that it's working okay. My receiver has eight channels, so I tried using AUX2 for the modes - no joy. So, either the receiver is bad or the APM???

    After solving the video monitor problem, I took my Elev-8 back out to the field to try flying fpv. Got the monitor working okay and turned on the dvr and took off. I was disappointed in the video quality but later suspect that I was not on the same vtx channel, but on an adjacent frequency.

    But shortly after takeoff, the quad experienced a momentary power loss, as if I throttled to idle and quickly returned to full power... This happened twice and spooked me so much that I made an quick landing. I tried to take off again, but not only experienced a brief power loss, but the monitor blue screened on me, so I landed again.

    So, now both aircraft are grounded. I am looking at taking the Elev-8 apart to search for an elusive electrical break. I'm thinking of pulling it's F.C. and putting it on the Tarot to try to determine which is the faulty LRU - flight controller or receiver...

    Also, the gimbal on the Tarot won't tilt on command even after I successfully bound the receiver and transmitter. I may have a bad connection at the servo plug which I am going to replace as soon as I get some servo pins. Or it may be that the gimbal itself is faulty, in which case, I'm looking at replacing it; if I go that route, I may buy a Trot T4-3D as it's a little cheaper than the Feiyu-Tech Mini 3D...

    Don't know what to do to appease the Gods - there are no virgins around to sacrifice!
     
  2. mozquito1

    mozquito1 Well-Known Member

    Get rid of the monitor, that's dangerous.
    I'd rather see static or a bit of a picture than absolutely nothing but a blue screen.
    Im a barebones acro flyer, (allegedly o_O)
    So when ppl start talking apm & GPS & whatnot I just think all the fun your missing out on. I test & then check every bolt before I go out, so when I get there all I have to do is switch on & do a quick range test.
     
  3. GlassKnees

    GlassKnees Well-Known Member

    I like having the ability to switch to RTL in case I get carried away and lose orientation - I can always take over manually once it is close enough. Yeah, I know how to figor how which way it's pointing when you lose orientation, but this makes it so much easier. Also, I like flying waypoint missions when I'm shooting videos so I can concentrate on the camera and let the autopilot fly the aircraft.

    The FPV thing is just something I want to try - yes, I fly manually by sight, but occasionally I'd like to try FPV. The blue screen thing may be due to the electrical problem on the Elev-8. Yes, I do physical checks before going out to the field, but I don't know how you check for electrical issues.
     
  4. LoneRCRanger

    LoneRCRanger Well-Known Member

    And then, crap happens, even when you think you've got all the bugs licked! It's the same with computers, they're big dumb boxes that depend on software making them run right. A bad program means the big dumb box stays dumb.
     
  5. GlassKnees

    GlassKnees Well-Known Member

    Solved the Flight Mode problem! I'm using a Spektrum AR8010T 8 ch receiver. It has two rows of ports and it does not indicate which pin is the signal lead. I figured out by trial and error that the ground pins are on the top of row one. The flight mode plug goes into row 2 and I mistakenly plugged it in so that the ground pin was aligned the same as in row 1m which is bass awkards.... reversing the flight mode plug makes it work! That might also explain why I coldn't get the gimbal tilt function to work. But I had the gear retract plugged in correctly - go figure...

    I should have the Tarot ready to fly as soon as I replace the servo plug foro the gimbal tilt leads - will test to see if I can successfully arm the copter later today.

    I flipped the props on the Elev-8 so that they thrust downward and tried running it at with the throttle wide open - no indication of power fluctuations, but I was getting intermittent video fluctuation with the monitor - not sure that I can rely on it for fpv purposes - will fly only in an open field and if I lose video I can always revert to flying by sight.
     
  6. Jackson

    Jackson USA member at large

    Isn't this what you have?

    AR 10e.JPG
     
  7. GlassKnees

    GlassKnees Well-Known Member

    It is the same but mine does not have the pin indications that you show. Maybe I have a knock off or an earlier one??
     
  8. Jackson

    Jackson USA member at large

    Well at least you got it sorted.
     
  9. GlassKnees

    GlassKnees Well-Known Member

    Took the Tarot outside and fired it up - was able to arm and run the motors. Didn't take off - just wanted to make sure that I can arm okay. I'm waiting on servo pins that should arrive sometime today to fix the gimbal leads and hope to have it fully functional.

    Elev-8 is a crap shoot... May try to take it out for a test flight later today...
     
  10. mozquito1

    mozquito1 Well-Known Member

    Shame you had to buy them pins I got a box full of all sorts of pins. & tx antenna wire with without u.fl connectors.
    Anyone in the UK is stuck & don't want to pay stupid money. Either PM your address & I will send you some or there is loads of it in old laptop's.
     
  11. GlassKnees

    GlassKnees Well-Known Member

    Golly, I appreciate it! But I live out here in the wild west - sort of.... Northern Colorado. I have a plethora of pins of the other gender, and those that I ordered should arrive today. I have a theory that the video problems might be due to my drawing power for the vtx and camera from the main power distribution harness for the motors. I plan to remove the bullet connectors and put a servo connector on the power/gnd leads and plug into the flight controller which gets filtered power from the APM power module. The reasoning behind my theory is that I put the props of the Elev-8 upside down and powered it up, opening the throttle and going moving the flight control sticks around - no evidence of power drops, but the video would blank out at higher power settings and come back when power was lowered - definitely something to do with main power fluctuations. I may also try a separate power source, say a small 450 mAH 3S lipo like I have on the Tarot. I will make the change and post comparison videos.
     
    Gyro Doctor likes this.
  12. mozquito1

    mozquito1 Well-Known Member

    That's what I did, my first build was dirty.
    Copper board pdb gave me terrible video.
    So I bought a separate lipo like you but flying time went down so I then got an LC filter which cleared it up loads. Then I found out about capacitors, & Bunged one of them on the mains. video was sweet. Still the odd line @ max throttle.
    So by the time I had bought the extras it dawned on me that a decent pdb was in order for the next build. Loads of extra space it gave me aswell.
     
    GlassKnees and Gyro Doctor like this.
  13. Gyro Doctor

    Gyro Doctor Electronics Tech for over 45 years

    :rolleyes: .... There are LOTS OF problems that can be attributed to "bad juice". Voltage sags, spikes, and noise are often taken
    care of with just the adding of a low ESR capacitor but it's even better when you put an active filter in the mix.
    My tried and proven fix that I put on just about everything is the POLOLU buck/boost regulators.
    They feed from 2.9 -32 volts and provide a clean, steady 4-12 volts at 2 amps for whatever you need.
    Voltage spiked? -> Clamped ... Voltage dipped or the Bats low? -> Boosted .... Noise on the line? -> Filtered :)
    IMHO it's the best $15 investment you can find ;)
     
    Last edited: Mar 14, 2018
    mozquito1 and GlassKnees like this.
  14. GlassKnees

    GlassKnees Well-Known Member

    I did a comparison of FPV video quality by using the quadcopter's main power versus using a separate power source:


    Also, I flew the Tarot today - camera gimbal works, but not the landing gear retract. I neglected to test it before going to the field - I later discovered that the servo pins for ground and signal are reversed - that's what caused my confusion earlier when I plugged in the gimbal servo plug. It is all fixed now - the Tarot is fully functional and the Elev-8 will be too as soon as I put the props back on properly and reconfigure the flight controller.
     
    Rick M likes this.
  15. GlassKnees

    GlassKnees Well-Known Member

    the last couple of times I've flown my elev-8, I've had problems with two flight modes that require GPS/compass: Loiter and RTL I recalibrated the compass twice now - the latest time, I compared the compass heading as shown in Mission Planner with the compasy on my iPhone and there was only a degree or two discrepancy, which is acceptable for the short distances I plan to fly with it. It occurred to me that perhaps the video transmitter might be interfering in some way with the compass - here's a top view where you can see the vtx in relation to the compass/GPS (the vtx is at the bottom, below the chassis - the small lipo next to the flight controller is used to power the vtx/camera):

    [​IMG]

    So this morning, I decided to try an experiment - take off without powering on the vtx/camera and see if I can get the aircraft to hold position in Loiter mode. It was a bit breezy but decided to try anyway. To my satisfaction, it held position despite the wind. So I landed, powered on the vtx/camera and took off again. This time, it seemed to hold position, but it would twitch a couple of times. I took over manually and brought it back to the parking lot and landed. So, I'm not sure what, if anything is going on. I will wait for a calmer day and repeat the experiment.

    BTW, I received better video this time after pointing the circular antenna downward. I might replace at least one of the antennas on the monitor with a circular antenna and see if I get better reception.
     
  16. Gyro Doctor

    Gyro Doctor Electronics Tech for over 45 years

    You should most certainly expect to get much better reception with two circularly polarized antennas compared to just one transmitting to a "stick". :)
     
  17. GlassKnees

    GlassKnees Well-Known Member

    My antennas (antennae??) arrived and can't wait to try them out. But I'm loathe to takeoff without insuring that there are no GPS or other issues. I bought a cheap laptop from someone in the neighborhood to use in the field so I could monitor telemetry from the aircraft prior to takeoff and during flight. But after installing Mission Planner, a driver for the USB 915 mhz transceiver, I couldn't get a connection. A traceback from M.P. said that the max baud rate for "the device" was 9160. But I the transceiver works fine on my desktop and I'm using the same version of M.P. on both computers.

    So, I tried connecting directly to the APM using a USB cable - M.P. recognized a different com port (COM 4) - set the baud rate to 115200 and it connected just fine. But when I try again using the radio (COM 3) at 57600, I get the same error. So I'm totally confused..... The software is the same, I'm using a known good transceiver, and the USB port can operate at a higher baud rate than the traceback implies.... AARRGGHH!!!!
     
  18. GlassKnees

    GlassKnees Well-Known Member

    I solved my laptop computer problem! I had to do some thinking about what I had tried and zeroed in on the problem. I had determined that the telemetry radios I'm using work, the Dell laptop is working and Mission Planner is also working. That left only one thing: the driver I was using. The radio uses an FTDI chip in front of the radio modem as a USB to serial conversion is needed. I speculated that the Silicon Labs driver I downloaded was somehow not compatible, so I went to the Dell downloads site and found an FTDI driver which I downloaded and installed - that worked!

    Here is the laptop with Mission Planner running and connected to my Elev-8 which is sitting off to the left on the workbench (out of view), pointed towards the computer. I turned on the camera,vtx to show live video being broadcast.

    [​IMG]

    Now I can plan missions down in the basement without dragging my aircraft to the upstairs office and I can take the laptop out to the field to capture telemetry during flight.
     
    Spork likes this.
  19. Spork

    Spork There is no spoon

    That's good news, Glass. Drivers can cause much frustration. Even thought the IT guy in me knows it should be one of the first things to check, somehow it always escapes me until I'm ready to smash something.
     
  20. GlassKnees

    GlassKnees Well-Known Member

    Well, I did install a driver that was recommended - it just hit me later that perhaps it was the culprit....
     
    Spork likes this.

Share This Page