Touble with Omnibus f3 flight controller and FS-iA6 Receiver BETAFLIGHT NO MOTOR RESPONSE

Discussion in 'First Build' started by Hoover Longtree, Aug 7, 2018.

  1. Hello. I am really confused here.
    I have no trouble setting up and connecting the radio to the receiver that it shows it is connected on my radio’s screen. And also the flight controller looks normal; it has one blue and one red light when connected to the battery. However, after I installed driver and connected successfully with Betaflight and turned on RX3(since it is a f3 fc) and set receiver to be Serial Based Receiver and IBUS, I tried to turn the radio but nothing happened and throttle level kept very low about 858. So I guess it’s the esc’s problem??
    Please helppp!!

    In this build I used:
    Racerstar RS20x4 4in1 ESC
    Omnibus fs Flight Controller
    FlySky FS-i6 Transmitter
    FS-iA6 Receiver
     
  2. dragger201

    dragger201 If it ain't broke, don't fix it??? You kidding?

    Hey Hoover...........the Flysky FS-iA6 Receiver does not support either iBus or PPM. There was some work done a couple years ago trying to make iBus work but about that time Flysky came out with the FS-iA6B receiver which supports both. The cost for both was very close so I think any work on modding the iA6 came to a halt. As far as I know the iA6 is a PWM only receiver.


    https://www.rcgroups.com/forums/showthread.php?2711184-Serial-output-from-FS-IA6-(Semi-I-BUS)
     
    Hoover Longtree and Jackson like this.
  3. mozquito1

    mozquito1 Well-Known Member

    Yes one wire per channel,
    4 for sticks & 2 Aux channels for arm & modes. Get the firmware cable & you can get to use all switches with the 10 channel update. But you will nerd the ia6b
    Ia6c, X6b to use ibus/ppm.
    Also the Aux channels have to be setup before any input shows in the rx tab in betaflight.
    Stick arm is dangerous so put arm on SWD = aux1 & modes on Aux 2 = SWC.
    Then do this in the Transmitter menu.
    Under Aux channels.
    Get the cable & ia6b or C, then come back & if need be we will run through it.
     
    Hoover Longtree likes this.
  4. mozquito1

    mozquito1 Well-Known Member

    Endpoints
    =1000 low
    1500 mid
    2000 high

    Lowest esc value needs to be above the low 1000 orno arm.
    In the motors tab when you move the slider note what value all motors spin up together. You want this as the lowest esc value. It should be above the 1000 endpoint for low point. Note lowpoint & esc low point are 2 different things.
    Same for the high point but I don't really bother I very rarely hit that.

    There is loads of diagrams for a pwm rx setup, just Google it.
     
    Hoover Longtree likes this.
  5. Ok thank you it works! I now can move around the drone in betaflight. However, it does not respond in the motor section of the betaflight. By just plugging in the battery the motors does not respond to my radio, so is it the esc’s problem?
     
  6. I soldered pdb’s grand and voltage to both esc and the battery wire, one on top the other one on the other side, hope that is not a problem??
     
  7. mozquito1

    mozquito1 Well-Known Member

    You got a picture battery goes to its own pads, esc go to there own +=
    Esc signal wires to motor ports 1-4
    Rx to a uart.
    To calibrate the esc you have to check the box, move the slider up, then plug the battery in, wait for the beeps to finish.
    Then move the master slider back down.
    Wait for beeps to finish. Esc's are now calibrated. All four should now move.
    Only with slider. Not with stick .
    Config tab you need to select which receiver type you are using.
    Pwm
    Ppm
    Serial rx
    Sbus depending on your tx/rx type.
     
    Hoover Longtree likes this.
  8. Ok thank you again. But when I calibrate, it does not give me the beeping sound when I plug in the battery.
     
  9. mozquito1

    mozquito1 Well-Known Member

    What endpoints you have in the configuration tab should match what is in blheli. That motor 2 values may be different Or you have a bad connection
    Dry Solder joint.
     
  10. Yes you are right. It won't work because of bad solder. Now that I can control thr receiver and motors in betaflight, but I cannot use the radio to make motor do anything. I tried to calibratr the esc but it wont make the serie of beeping sound. My fc used to beep when I plugging the usb but now it does not beep and just shows the red and blue light.
     
  11. mozquito1

    mozquito1 Well-Known Member

    The flight controller does not beep.
    it is the motors that beep.
    Go back through the steps I mentioned above. If you can see the esc in blheli then it's OK. You may just have to set both endpoints & then do the same in the configuration tab in betaflight but make sure they match.
    The only other thing I can suggest is a board reset on the setup tab & start again. It's all fun.
     

Share This Page