Need help Repairing Phantom 2 Vision Plus

Discussion in 'Experimentation' started by Nick, Feb 2, 2016.

  1. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    Hello all,

    My Girlfriend's Dad's Friend's Phantom took a swim in the Gulf and didn't bring its floaties. After the salty abyss choked the life out of it, it was then given to my Girlfriend's Brother (who has a Phantom 3 standard) for "parts". To re-iterate this is a Phantom 2 Vision Plus.

    I wasn't so sure the phantom was a pile of junk and asked to be allowed to repair it.

    Currently, I have replaced 2 ESCs and the patch on the GPS that's been know to be "Delicate". So now I have a grand total of 3 maybe working motors and the 4th having a burnt out ESC that will soon be replaced as well.

    Also a note I do not have a genuine DJI battery and am simply using a cheap 3S 1800mah lipo and alligator clips to test the phantom... There will be no investment in a real $100 battery until I know the phantom actually works.

    When I power it on it does a light sequence of something along the lines of "Red, Yellow, Green, Yellow, Red" and then no lights after that.

    So lets list the good things so far:
    1. 3 of the ESCs blink and chirp in union.
    2. The transmitter does bind to the phantom and I can confirm the stick readings through the Phantom being plugged into my pc through the DJI assistant software.
    3. The Wi-Fi Access Point does show up on a phone and can connect through the DJI app.
    4. ..... Some fourth thing.

    Now the list of bad things:
    1. The fourth motor with the damaged ESC blinks a different sequence of lights on power up and doesn't seem to vibrate the motor while it chirps like the other motors.
    2. No motors spin up or ESCS light blinks with the CSC execution.
    3. DJI assistant software reads Compass Error "Abnormal Compass Data" with all the compass data reading as zeros.
    4. No GPS information in the DJI assistant software.
    5. Cannot get Transmitter to connect to RC Assistant software for firmware update and calibration (already update the phantom when it connected to the DJI assistant)

    Probably the most annoying things are nothing happening on the CSC and the fact that the transmitter will not connect to my pc.

    For the transmitter, I plug it in and it installs as a serial device (Not a DJI device even though I tried to install the DJI Drivers) showing as like "COMPORT4" or something. The Phantom also installs as a Serial Device "COMPORT6" but it shows up on the DJI assistant just fine. Yes I do have the separate RC Assistant Software but no matter what I do I cant get it to show up.

    Any thought?
     
    GJH105775 likes this.
  2. RENOV8R

    RENOV8R Well-Known Member

    Hit it with a hammer?
     
  3. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    Thanks but no thanks. I don't think a hammer can help in this situation.
     
  4. GJH105775

    GJH105775 Avid Linux User, and U.S. Air Force 1C6x1 Moderator

  5. holtneil

    holtneil Well-Known Member Moderator

    Hi mate ok the transmitter will update off the naza m so no need to plug it in to any thing if there is an update you can do it from the update tab, it may be worth reflashing the Naza M as the water my have done some strange things
    GPS and compass need calibrating out side never do this indoors and never with any props on , it can some thimes take the Phantom 3 mins to find all sat signals after compass calibration to calibrate flick the atti gps switch 5 times till led lights up and spin the phantom 360 degs till led changes to green I think then tip the phantom on its nose and turn 360 degs till led goes out now place on the floor till it finds it GPS and locks on and red flashing means your not got all sats locked in some times you have to move the phantom 2/3 feet and calibrate again here is a video of the leds and what the lights mean its the phantom 1 but they are the same
    I hope this helps if not come back to me and we can re think things
     
  6. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    Hello,

    I'm guessing the phantom in that video is of a previous model because my phantom has no center LED indicator. There is simply a micro usb plug in that place. I assume the single center LED on that model is reflected to the leds emitting from the ESCs on the arms.

    Flipping the switches multiple times does not seem to make any indication on the phantom that it is ready for a compass calibration. I know the switches on the transmitter work because it shows the inputs on the DJI assistant software.

    I tried the basic and advanced calibration through the DJI assistant software (note I did all this indoors which may have been a mistake).

    What are the conditions that would cause the CSC execution to do nothing. Broken GPS( Even though I replaced the patch on it) or compass? Maybe because the 4th burnt out ESC is still plugged in and there's some failsafe to restrict it from taking off? I have read online it will blink 4 red lights if it requires a compass calibrations when you attempt the CSC.
     
  7. holtneil

    holtneil Well-Known Member Moderator

    Hi mate sorry been on nights try without gps and compass plugged in this is how the Naza lite comes same chip set see if you can get it to do any thing
    Yes the one in the Video is a phantom 1 but the Naza M is the same the leds are in the arms on the newer phantom
     
  8. holtneil

    holtneil Well-Known Member Moderator

  9. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    I previously tried it without the GPS or compass but that was before I repaired 2 of the ESCs. I will try it again but unfortunately I won't get my hands on it till Monday because I'm going out of town for the weekend.

    I read somewhere that with the newer Firmware the Phantom won't work without the GPS plugged in but I could be wrong since I know next to nothing about phantoms except that they are a pain to troubleshoot after being drowned.

    On a separate note, do I just use the micro usb connection to reflash firmware or do I need one of those usb Serial tool things.

    Thanks for the replies by the way.
     
  10. holtneil

    holtneil Well-Known Member Moderator

    I found this as well it looks as if there is a camera problem you have these red lights
     
  11. holtneil

    holtneil Well-Known Member Moderator

    Hi this may help you
     
  12. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    Noting on the first of the 2 videos you just posted, my phantom DOES make the beginning light sequence (Solid Red, green, yellow, red, green, yellow) for the 3 working motors and then NO lights after.

    Regarding the second video, I get no red lights even though both the gimbal and camera are removed(I haved tested them yet because I wanted to get the rest of the quad working)
     
  13. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    Thanks for that firmware video, it gives me more things to investigate.

    Things that I realized from it:
    1. After I upgraded the firmware I was greeted with a red flashing and beeping until I unplugged the battery. The video says that this means it failed to upgrade and requires a hard reset.

    2. You cannot perform the CSC to spin the motors while the micro-usb plugged in. I'm pretty sure I only tried to spin the motors with the cable plugged in.

    So now I need to Hard Reset, update the firmware correctly, then try to spin the motors without the cable plugged in.
     
  14. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    One last thing before I try to hard reset and re-upgrade, I am using a regular old cheap 3S 1800mAh LIPO instead of a Genuine DJI Intelligent Battery. Would this throw any errors or stop the phantom from upgrading?
     
  15. holtneil

    holtneil Well-Known Member Moderator

    Sorry cant say , I think the battery is not linked in that way , I wonder if the 1800 is man enough the phantom 1 used a 2200 mah but your not flying it just testing so should be ok just testing , if it was me I would not buy an £180 till I know it will work so I would test the same way as you
     
  16. Nick

    Nick About to throw an arduino..*cough*F450 Master Race

    Well no matter that I unplugged or plugged into the Phantom (GPS, compass, gimbal, camera) the hard reset and firmware upgrade always failed. Is there a better way besides a hard reset and using the DJI assistant to upgrade?

    Also, would the fact that I only have 3 of the 4 motors plugged in cause the firmware update to fail?
     
  17. holtneil

    holtneil Well-Known Member Moderator

    Hi I never had these problems but I never had one in the drink , you said your having an ESC on order wait till it comes then try upgrade , I wonder if the water has tracked the across the board and has damaged it , the Naza M is the pricey part of the Phantoms and if this has gone there is only 2 things to do ask DJI if they can fix it or give you one at discount ,the other thing is find a Phantom that has been crashed but the Naza M is still ok and buy it from them Cheap
     

Share This Page