Help DEVO 7 with FPV racer

Discussion in 'First Build' started by CasualFPV, May 5, 2018.

Tags:
  1. CasualFPV

    CasualFPV New Member

    So recently I decided I wanted to get into FPV drones, I decided to build my first drone because I knew it would give me the experience and knowledge when I need to fix it down the road. I mostly followed this guide with a few changes I decided to make (parts list below):



    I only changed 2 things about the build, I decided to get the Runcam split 2 and opted for a controller that I thought would feel better to use, the Walkera Devo 7 with the RX601 receiver.

    After building the drone plugged it into the PC and set it up in CleanFlight, everything seemed to be working the channels all respond correctly in CleanFlight but when I unplug the drone from my PC it wont respond to anything, I've searched through countless forum threads and YouTube videos trying to find people who have had the same problem but I cant find a solution, I've also tried setting an arm switch as well as setting a fail-safe switch but nothing I've tried works. Does anyone know how to fix this issue?

    Here's the important parts in my parts list:
    ESC: Racerstar RS20Ax4
    Motors: Racerstar Racing Edition 2205 2300KV 2-4S Brushless Motor
    PTB: Matek Systems PDB-XT60
    Flight Controller: SP F3 Deluxe Acro 10 DOF for FPV Racing Drone
    Walkera DEVO 7 Transmitter
    Walkera RX601 Receiver
     
    Dugdog47 likes this.
  2. Jackson

    Jackson USA member at large

    Are saying the DEVO's sticks 'all respond correctly'?
     
  3. Dugdog47

    Dugdog47 Well-Known Member

    This is very close to the quad I'm doing soon. I hope you get your issues sorted out and be shure to let us know what happens.
     
  4. CasualFPV

    CasualFPV New Member

    So everything seems to be working fine in cleanflight or betaflight (I've tried both) but I think what's happening is the drone is having a problem arming, I've tried changing the arming angle which is one solution I've seen pop up often but that didn't seem to work
     
  5. mozquito1

    mozquito1 Well-Known Member

    Maybe the esc's are not configured properly. Does the firmware match what is on the top right of the configuration tab. Near failsafe. Eg oneshot125 is default I think.
    If everything else is OK then this wrong protocol setting would stop you from flying.
     
  6. mozquito1

    mozquito1 Well-Known Member

    Or if the gyro is way off calibration.
     
  7. RENOV8R

    RENOV8R Well-Known Member

    In the receiver tab, have you adjusted all your endpoints to 1000-2000? Also as your ESCs are DShot capable, I'd set your protocol in the configuration tab to DShot 300. This will eliminate the issue of calibration and min throttle.
     
    BL Swagger and mozquito1 like this.
  8. BL Swagger

    BL Swagger Well-Known Member

    Make sure the battery is plugged in :D
     
  9. CasualFPV

    CasualFPV New Member

    Thanks for everyone's help! I was actually able to solve this simply by switching to betaflight
     
  10. CasualFPV

    CasualFPV New Member

    Thank you for the suggestion, however I had already tried that and for some reason it was not working in cleanflight
     
  11. RENOV8R

    RENOV8R Well-Known Member

    It was probably just a firmware/software incompatibility, glad you got it worked out!
     

Share This Page