Global x183 is not taking off

Discussion in 'General Discussion' started by Gimhan Sumanasekera, Feb 2, 2018.

Tags:
  1. Lloyd Quick

    Lloyd Quick Member

    One long and 2 short flashes means your calibration attempt failed.
    Please recalibrate again. I suggest watching the video on u-tube.
     
  2. Thanks for the "info" I'll give it a go when the replacement transmitter arrives, Mine is a dual GPS and they have indicated that a replacement transmitter will be sent.
     
  3. Lloyd Quick

    Lloyd Quick Member

    Let me know when you get your new transmitter how it works.

    Lloyd
     
  4. Will do, thanks for your input.
     
  5. Mine is the Dual GPS X6 Follower and it's the wrong remote, Chinese supplier has offered 40% refund and I keep the drone, I don't know why they won't just exchange the remote! I finally calibrated it after countless attempts and it flies OK. My advice, only purchase from proven suppliers.
     
  6. I got it to fly but without the follow me and 360 functions, all I want is for them to replace the remote.
     
  7. Rick M

    Rick M Absent-minded professor

    I always use PayPal for purchases from overseas suppliers. That way I can dispute the charges with PayPal if I have an issue.
     
  8. Lloyd Quick

    Lloyd Quick Member

    I am pleased you got it to fly.

    Lloyd
     
  9. Have ordered new drone from Australian supplier with the same functions ( Much higher cost but less aggravation )
     
  10. Kainite

    Kainite New Member

    Hi, I do have the same problem my don't have dual gps and the buttons don't work so i don't have "follow me" with camera 4k (bad publicity), but after fly for a few minutes or less the rx battery stays at 6.9v and the lights do like code more ( -.. -.. -.. ) and never go (------) and don't fly it seems that this is blinking code is regarding the batteire being low? usually calibration dues ( .. .. .. ..) but there are no code information on the manual and support don't exist, could anyone have the lights code meaning?
     
  11. Jackson

    Jackson USA member at large

    I'm assuming the 6.9V is triggering the low battery voltage warning. Use a meter and check the bat voltage right after you charge it, it should be around ~8.4V.
     
  12. Lloyd Quick

    Lloyd Quick Member

  13. Jackson

    Jackson USA member at large

  14. Lloyd Quick

    Lloyd Quick Member

    That looks great!

    Lloyd
     
  15. Kainite

    Kainite New Member

    That is actually what i get after a full charged but since this is the original batteries as Lloyd mention i can only run for 3min or less. Thanks for the tip.
     
  16. dweber

    dweber New Member

    Hope I can jump in here. The charger for this follower gps 183 is driving me nuts. Sometimes it will blink green and red, then it will show two small lights green and red solid. I assume when it has stopped blinking and is solid green and red than the battery is charged. Even then it is a guess as to what the charge will be, but it has never gotten above 7.0 mostly stays in th 6.4 range and that may be after 3 hours of charging. Where can i get a real charger for this battery? Drone hasn't flown but one time reasonably well then returned home automatically and hasn't hardly flown decent since. Thanks for your help.
     
  17. 2Hover

    2Hover Member

    Hi, wondering if you solved the problem yet? It appears Lloyd Quick had same problem with same drone and solved it by re-calibration.
    Did you set your sticks to the "mode" you're used to? ex: In the US. its left= throttle.
     
  18. Lloyd Quick

    Lloyd Quick Member

    I went on u tube and watched many videos of calibration, and tried each one, many times before I was successfully.
    Please keep trying.

    Lloyd
     
  19. Craig Johnson

    Craig Johnson Member

    I'm having the same issue with my X183.

    The drone appears to successfully complete its prelaunch initialisation sequence, and pulling both joysticks on the radio down and outward starts all four motors in idle. But giving it throttle now does nothing! The drone stays on the ground at idle speed.

    Almost immediately after power-on, all of the LEDs in the drone blink the following in unison (I believe is a fault code):

    Two brief flashes, pause for ~700ms, longer flash. Cycle repeats until the drone is powered down.

    I ensured that the flight battery was fully charged (the radio's display indicated 8.4 volts) and I power-cycled the drone multiple times -- still no joy. [​IMG]

    (Edit 10-20-18 6:12am PDT): I just verified that this is in fact *NOT* the battery.
     
    Last edited: Oct 20, 2018
  20. Lloyd Quick

    Lloyd Quick Member

    Two brief flashes, pause for ~700ms, longer flash means calibration failed.

    Go to You Tube and search for "global drone x183 calibration".
    Look at 4 or 5 Videos and try calibration their way.
    It took me about 5 tries to get it to work.

    Let me know how it works for you.

    Lloyd
     

Share This Page