Camera does not work on new Hubsan H501S x4

Discussion in 'General Discussion' started by Bladerunner, Jan 14, 2018.

  1. Bladerunner

    Bladerunner Active Member

    I think you have hit the nail on the head. From what I have now read/watched on youtube, you should always eject the card, by doing so you are telling the device that the card is off the radar, so to speak. Also, as you say, you should stop the recording, then wait, up to a minute even, before turning off the parent device, to ensure you give it time to complete the data writing to the card.

    In my case, in the course of my work, I used to take 30 to 50 photos a day. I got used to simply then plugging the canon sureshot camera straight into the laptop for processing. In fact I forgot that the laptop even had a card slot, because I never used it.

    So I bought a new drone and took some footage. As was my custom, then plugged it into the canon camera: no playback. Assuming a card fault, bought a new card.
    Took some more drone footage. This time, put card into Android phone. Voila: Got a footage recording.
    Then, foolishly tried same card in canon camera. No footage. Whilst card was in camera, tried to take a couple of shots. it took them, but behaved strangely, i.e: double clicking instead of single etc. Took the card out and put it back in: result: error. Then put the card straight into the laptop: result: error. Then back into the Android Phone: result: error. Conclusion IMHO: the canon camera has corrupted the card.
    Interestingly, the drone RC screen is now showing a card present logo indication, permanently, i.e: whether or not a card is actually in the drone. (Separate issue I know, I am returning the drone.)
     
    Spork likes this.
  2. Spork

    Spork There is no spoon

    Yeah - I think it's one of those things that SHOULD be very simple, but due to so many vendors' different implementations, it sometimes isn't so simple.

    Glad to hear you are returning the drone and hopefully the replacement (or different model) will work much better for you. Funnily enough, after a crash knocked the camera off the quad, it will now sometimes save video and sometimes not. But in my case, the video is really just an extra that I don't care much about, so I just removed the camera. I'll worry about video on my next quad as this one was only ever meant to be my "learn how to fly" quad.
     
  3. Bladerunner

    Bladerunner Active Member

     
  4. Bladerunner

    Bladerunner Active Member

    Conclusion IMHO: the canon camera has corrupted the card.

    Having done a bit more homework, this is now more than IMHO. The canon camera has definitely corrupted the card. The canon camera can only handle a 2GB card and, in my stupidity, I put in a 16GB card that already had files written to it (from the drone camera). Lesson learned.
     
    Spork likes this.

Share This Page