Camera does not work on new Hubsan H501S x4

Discussion in 'General Discussion' started by Bladerunner, Jan 14, 2018.

  1. Bladerunner

    Bladerunner Active Member

    Hi. Only flown the drone once. It flies excellently. No complaints at all except I cant get anything from the camera. I have inserted a brand new SD card (the right way) and tested the SD card in another camera. The card works fine.

    The drone transmitter screen recognizes the SD card. FPV/ Camera view on the screen is fine. The screen camera functions all work as per manual i.e: photo and video buttons, and video recorder timer on screen all working. Also when you operate photo and video buttons, a blue light on the base of the drone comes on and goes off in conjunction with on/off operation of the buttons, which I hoped meant that the camera was working. Since the drone’s one and only flight, I have tried many times indoors to get the camera to work to no avail. If anyone has any advice, I will be most grateful.
     
  2. RENOV8R

    RENOV8R Well-Known Member

    How are you trying to play back images?
     
  3. Bladerunner

    Bladerunner Active Member

    Thanks for reply. SD card out of drone and into ordinary camera, then into laptop. I know the card is OK because I have taken pictures using it in the ordinary camera and then viewed them on the laptop no problem.
     
  4. RENOV8R

    RENOV8R Well-Known Member

    Hmmmm sounds like a dead camera ,may have to send it back for replacement. The only other thing I can think of is that the card is incompatible. Is it a Class 10?
     
  5. Bladerunner

    Bladerunner Active Member

    Yes, logo at top of card packaging says "Speed up to 98MB/s**" with a 10 in a circle at the top i.e: (10). I take it that means it is a class 10 card?
    I think you are right that the camera may be dead.
     
  6. Jackson

    Jackson USA member at large

    FWIW it's not unusual for some devices to be a bit picky.
    What brand and how many gigs?
     
  7. Bladerunner

    Bladerunner Active Member

     
  8. Bladerunner

    Bladerunner Active Member

    Sandisc 16GB Class 10.



    I have looked into this a bit more, especially about SD cards. Now, the appliances regarding the situation are

    1. Drone (brand new)
    2. Canon camera (at least 10 years old)
    3. Laptop (at least 10 years old)
    4. Android phone (new).
    So, I bought a new Sandisc, class 10, 16GB SD card and plugged it into the drone. Took the Drone for a flight and took some video. Then plugged the card into the camera. Then connected the camera to the laptop. No footage.

    Bought a second new Sandisc SD card (same class as above). Plugged it into the drone, went for a flight and took some video. This time I then plugged the card into the phone. I got some footage!
    I then tried the same card in the camera and directly into the laptop. The camera gave a card error message, the laptop said the card required formatting but would not allow formatting (in any of the format systems). I them put the same card back in the phone and it now appears to be corrupted. The phone will now not permit the footage to be played and says the card requires formatting but will not format beyond 20%.

    Having looked at various Youtube videos, I have come to the conclusion (I am no techie) that both the laptop and camera are too old to recognise the new SD cards and have possibly corrupted them so that the phone cant play them or, it appears, format them. Where do I go from here? Very grateful for any thoughts?


     
  9. Spork

    Spork There is no spoon

    Sorry, I don't have an inexpensive solution for you, but these are the situations I use to convince my wife to let me buy new stuff. :D
     
  10. Bladerunner

    Bladerunner Active Member

    But see below. This is why I am so confused. The camera/and or laptop did appear to recognise the new card then.
     
  11. Jackson

    Jackson USA member at large

    I would have tried another brand. Does the quad have it's own format capability?
     
    Rick M likes this.
  12. Gyro Doctor

    Gyro Doctor Electronics Tech for over 45 years

    Good point, sometimes the formatting process coming from the quad vs coming from the 'puter (or another camera) don't want to "play nice" together.
    If you CAN format it in the quad do that so you know it's recording onto the card in the quad cam's proper format. The computer should be "backwards compatible" and able to read the card. Formatting it in the computer then recording onto it from the quad however will likely cause problems.
     
  13. Bladerunner

    Bladerunner Active Member

    Unfortunately not.

    There is an SD card slot in the controller but this appears to serve no function in the 501s drone model. In fact one Youtube film on the subject suggests it's only use is to carry a spare card for the actual drone!

    I have been right through all the programs on the controller but there is nothing relating to SD cards. As I said previously, I did initially, manage to play back some footage from the drone, on the phone. This was using a Sandisc Class 1, 16GB card. Should I try a Sandisc Extreme (maybe with 32GB capacity)? I understand these are faster? From what I have posted, do you think it would be fair to say that the problem appears to be card incompatibility rather than the camera itself?
     
  14. Jackson

    Jackson USA member at large

    So basically you do not have a standalone card reader? And your laptop does not have one either?

    You should have one. Seeing as you seem to be hung up and Sandisk.
    https://www.ebay.com/itm/Micro-SD-t...095897&hash=item36032b9d4b:g:kBAAAOSwSrNaGgFK

    That said I'd contact Hubsan, they are pretty good when it comes to standing by their products. But the squirrely way you are trying to read the card might might cause them to pause.

    FWIW a 16G card should easily give you well over and hour of 1080p/30fps video. My old Dazzne cam does about 2 hours.
     
  15. Bladerunner

    Bladerunner Active Member

    Thanks for confirming the card is OK, which is what I asked.

    So , basically I don't have a standalone card reader? No, I don't. No one told me I had to have one.

    But the squirrely way you are trying to read the card might might cause them to pause. Why? I am a customer who bought one of their products. If the card should be read in a certain way, why would that cause them to pause? Can you explain? Why squirrely?
    Seeing as you seem to be hung up and Sandisk. Did you mean to say " You seem to be hung up about Sandisc?" If so, where did I say I was hung up about Sandisc in the thread?


    That said I'd contact Hubsan, they are pretty good when it comes to standing by their products.
    Not according to many Youtube videos. Their customer service to the UK seems to be appalling.

    Your post has not touched on any of the points I mentioned.
     
  16. Spork

    Spork There is no spoon

    Yeah, you should probably get one. Here's an inexpensive one on amazon that does SD and MicroSD: click

    What I think @Jackson means by "squirrelly" is that you are going from the quad to the camera to the PC. Most folks take the card from the quad and go straight into their computer. The intermediate step on the camera adds an unknown to the equation.

    Again, I'm not Cowboy, but I interpret his meaning to be that you were using Sandisk, were given advice to try another brand, and then you came back with questions on using another Sandisk card. Nothing against Sandisk - I use them and others in my DSLR cameras. Jackson and Doc were simply trying to eliminate the possibility of card incompatibility.

    Not sure if you've seen this, but this guy talks about solving the problem by formatting the card in his PC:
    https://medium.com/@sergey_nog/problems-recording-videos-in-hubsan-h501-drone-185fe324e84

    He talks about formatting every time he uses it - which doesn't make a lot of sense to me. But I think it's worth a shot at least once to see if it helps.

    Regarding larger cards, I saw several indications that this quad not work with cards larger than 32GB. Also the SD card slot in the controller isn't an extra card holder, it's for updating the controller firmware.

    Hope it helps.
     
    Gyro Doctor likes this.
  17. Bladerunner

    Bladerunner Active Member

    Most folks take the card from the quad and go straight into their computer.

    Sorry if I wasn't clearer. I did put the card straight into the computer (as well as via the camera another time). But whether straight into the laptop or via the camera, the result was the same: no footage. The card did initially work with the phone, but no longer does. This why I thought that the laptop and the ordinary camera might not recognise the new card because of their age? Also the card stopped working in the phone after I had tried it in the laptop/camera which is why I assumed that they (laptop/camera) had somehow corrupted the card?
    Also if the laptop will not recognise the card data, why would it recognise the same data via a reader?

    Regarding larger cards, I saw several indications that this quad not work with cards larger than 32GB

    The card I have been attempting to use is a Sandisc Class One 16GB. I have no particular fondness for Sandisc but it is the only brand my local store stocks. As I said, this card did play back footage from the drone initially when inserted in the phone. Does this not indicate that the drone camera is working and that the card in question is compatible with it? And that the problem appears to be that, not only is the laptop not recognising the card data, but is corrupting the card, so that when I try it in the phone again (after trying it in the laptop), the card no longer works?
     
  18. Spork

    Spork There is no spoon

    Gotcha. I misunderstood and thought you did not have a card slot in your PC and were using the camera one with a USB cable connected to the computer.

    Yes, it does seem to indicate that everything works. In the dozens of cards I've used in cameras over the years, none have gotten corrupted to the point where they no longer worked. I've had a few that were corrupted due to pulling them out before they were done un-mounting and several others that were corrupted for unknown reasons, but they always worked again after reformatting. The link I provided above tells me that this may not be an uncommon occurrence with your quad. But it seemed to work for him, so I would it at least give it a try.

    The reason I tossed in the comment on larger cards wasn't because you said you used one that large, it was to help you and any future users with this problem the trouble of trying a card that is too large to be used by the quad.
     
  19. Bladerunner

    Bladerunner Active Member

    Thanks Spork. I have tried to format the card in the laptop (using all 3 available format systems): result : "cannot format" message; in the Canon camera; result: "card error" ; in the Android phone: result: formats to 20% and goes no further. Conclusion (in my humble opinion): Card is corrupted beyond repair but I still have no idea how the corruption occurred.
     
    Spork likes this.
  20. Spork

    Spork There is no spoon

    I would tend to agree. I'm sure you're already planning to, but my next step would be to grab a brand new card and try it in the quad (unformatted) and test it. If that doesn't work. I would try formatting according to the instructions in my previous post and then try again. If that failed, I'd be sending the quad back.

    Regarding corruption, early withdrawal seems to be the biggest culprit in my experience. You should always "eject" your card from the computer - as skipping this step is an easy way to corrupt your card. On the camera side, even with a fast card, the device doesn't always write all the data to the card instantaneously. They typically have some sort of buffer memory that the data is written to by the camera and then a process on the device writes from the buffer to the card. This process normally only takes a few seconds or less on fast hardware. I wouldn't expect to take more than 10-15 seconds, but I've seen some posts recommend waiting a minute or more. You may want to play around with that. *Note, the above info is based on my experience with mid-high end camera equipment - not specifically quads - your mileage may vary.
     

Share This Page