Using Venom batteries with MJX Bugs 3 Battery low signal

Discussion in 'Ready to Fly Quads' started by Gene F., Jan 9, 2018.

  1. Gene F.

    Gene F. New Member

    I bought 2 Venom Fly 2s batteries to use with my MJX Bugs 3 drone. The batteries are 2 cell 2,000 mah/30C.

    For some reason batteries last only about 3 minutes before Remote Control and drone start flashing "low battery". Once drone lands the battery is showing 7.95V or 74%, which means battery still has plenty of juice to fly on.

    The stock battery - 1,800mah, 25C 2S is showing 7.57V and 31% upon low battery alarm and landing shortly after. I can get around 10 minutes of pretty aggressive flying from the stock battery.

    What is the problem here? I charge both batteries to 8.4V using Hi-Tech charger - all cells are properly balanced. Can you recommend any other battery for this drone or should I just use stock?

    What are your thoughts?

    Thanks!
    Gene.
     
  2. Jackson

    Jackson USA member at large

    Seems odd, especially since Venom carries a premium price tag and are well reviewed. How are you plugging them in to the Bugs?
     
  3. Gene F.

    Gene F. New Member

    I made my own XT30toXT60 adapter. Do you think this is it? Maybe it is my soldering?
     
  4. RENOV8R

    RENOV8R Well-Known Member

    Don't think so, as the XT30 is rated up to 30 amps with 60 amp burst. And if you had the polarity reversed......well...........you'd know.
     
  5. Jackson

    Jackson USA member at large

    That's where I'd look, when troubleshooting you can't assume anything. That's the only non standard, wrinkle in the equation. Like I said those Venoms are well reviewed on Amazon and should be as least as good as the stock batteries. It just seems odd that there is such a difference in performance, 3min to 10min. I'd either carefully make or buy a new adapter.

    Do the Venoms have an XT60?
    https://www.ebay.com/itm/XT60-Male-...147135?hash=item3d553e3c7f:g:17QAAOSwhgJZYoZ4
     
  6. Gene F.

    Gene F. New Member

    Yes, they have XT60. The thing is - they maybe performing OK, it is just LVC. Maybe it i just coming too soon? Is that possible? Look at the voltage!
     

Share This Page