Syma X8C Fast Blinking Lights and Controller won’t Bind

Discussion in 'RTF Modification & Repair' started by DanC, Mar 1, 2016.

  1. DanC

    DanC Active Member

    Hi Guys,


    I need some help with my quadcopter. I’m completely new to this hobby, and I recently bought myself a Syma X8C. Before that I just had one of those small USB rechargeable helicopters that you fly inside the house.


    I received the quad about 10 days ago and set myself to the task of learning how to fly etc… I was doing great progress and only had minor crashes, had to replace the prop guards a couple of times, but they’re only soft so they break easily.


    Last Sunday I went out to fly, as I’m still learning I started low, 2-3 feet off the ground. About 10 seconds after I took off I noticed I started loosing power and the quad landed, I obviously cut the throttle, but the propellers stayed spinning for about 60 seconds or so. During that time I tried to re-bind the remote, turned the remote off and on and tried to rebind again and nothing. Eventually when the props stopped the LED lights where blinking fast and I couldn’t bind the remote anymore. I’ve tried all sort of combinations, putting the quad on a flat surface before turning it on, turning the remote before and after turning on the quad, new batteries on the remote, etc…


    Here’s a quick video I took of the issue:


    Can someone help me figure out what’s wrong and how to fix this?


    Thanks!
     
    Last edited: Mar 1, 2016
  2. RENOV8R

    RENOV8R Well-Known Member

    The first thing I'd check is if the battery in your quad has a proper charge. Have you tried a different one? Also, have you done any damageto the antenna on your TX?
     
  3. DanC

    DanC Active Member

    I have 4 batteries, al of them do the same thing. Tried charging them and still the same thing. Don't think I've done any damage to the TX antenna, I did suspect the TX at first and opened it but everything looked good from a visual inspection. And on the LCD on the TX everything indicates it's working as expected. I haven't opened the quad yet.

    I really love this quad and I'm sort of already invested on it, bought 4 batteries, spare props, guards, landing skids, 2 extra motors and even a carry case for it. So I'd really like to fix it, and even consider buying a new one if this one can't be fixed.
     
  4. Jackson

    Jackson USA member at large

    I guess you could try moving the TX further away during the bind process. I think your only option now is to open it up for a visual inspection. First check the RX antenna.
     
  5. DanC

    DanC Active Member

    Thanks, I'll try to do that tonight.
     
  6. DanC

    DanC Active Member

    So I just opened the quad for a visual inspection and can't find anything wrong. No lose cables, the RX antenna is in place and looks ok, everything looks ok in the board and nothing looks burned or damaged in any way. I'm including a few pictures in case anyone with more experience on this things than me can shed some light.
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    So that's it... not sure where to go next....
     
  7. Jackson

    Jackson USA member at large

    Super pictures. Well since you got it apart you may as well pull the board and look at the underside.
     
  8. DanC

    DanC Active Member

    I did that actually... It looked normal.
     
  9. Jackson

    Jackson USA member at large

    So can you solder?
     
  10. DanC

    DanC Active Member

    It's been a while since the last time I did but I think I can manage. Would have to buy a soldering iron though, I use to always use my dad's! And a multimeter?
     
    Last edited: Mar 2, 2016
  11. Jackson

    Jackson USA member at large

    Well if you're a gambler, maybe it's the Controller that's bad, not the quad. Do you know anyone with an X8?
     
  12. DanC

    DanC Active Member

    I don't know anyone with an X8 unfortunately. My hunch is that it's not the Controller, because of the behaviour on the quad, but I could be wrong. I say this because usually when you turn the quad on the lights will first blink fast, then slower and then slower again, at this point is when you can bind the Controller to the Quadcopter. See this video that shows what I'm saying:


    In my case when I turn the Quadcopter on the lights just stay blinking fast. The controller on the other hand is behaving as it usually does. Again, I could be wrong!
     
  13. Jackson

    Jackson USA member at large

    Attached Files:

  14. DanC

    DanC Active Member

    Sounds like lots of fun! I'll give this a go, I'll have to invest in a Soldering Starter Kit and a Multimiter but something tells me I'll be needing them in the future now that I've got into this hobby! I'm already considering building my own quad some day! Damn this thing is addictive.

    So I'll order the board and I'll make sure to capture everything in this thread as it might help someone else eventually. The worst thing that can happen is that a new board won't fix the issue, in which case I'd need a new Controller, and they're really cheap too, around 3 euro more than the board!
    Apart from this two parts, there's nothing else that could be causing this issue right?

    Now that you mentioned this, what type of grease do you recommend for the gears? I recently bought this Silicone Grease, but I have a feeling that while this might be ok for the motors I might need something thicker for the gears.

    Thanks a lot for your help so far.
     
  15. Jackson

    Jackson USA member at large

    Your guess is as good as mine. :)
    Probably.

    FWIW you may want to add a jst pigtail for some future additions that need power, like a gimbal, while you got it open.
     

    Attached Files:

  16. DanC

    DanC Active Member

    Oh dear... :(

    Good point... this video also shows an interesting mod.
     
  17. Mike H.

    Mike H. Toy Quad Builder

    Looks as if youve done everything but actually re-calibrate the board..The binding process and it being on a level surface is not re-calibrating...Thats binding.

    The quad losing power slowly than stopping was an indication of low voltage from the battery which the board is designed to detect and slowly shut down power....Just because you charge a battery doesn't always mean its charged fully..You can have false peak readings from the charger and possibly a bad battery itself despite it being new.

    I would Look for the " SYMA X8C Re-Calibrating procedure" and follow that before i wrote off the board as being faulty..Also make certain the TX has fresh batteries in it.
     
  18. Jackson

    Jackson USA member at large

    Don't like the 2 battery thing. Way too much added weight (~103 grams) which will stress/heat the motors and the longer flight times will add to the overheating.

    Many are adding the Walkera plastic gimbal and action cams. Getting flight times at <5 min. That combo weighs in ~210 grams.

    This looks interesting.
    http://copterlab.com/2-axis-mobius-gimbal

    Couple that with a RunCam 1 or 2 and you get a total weight of ~ 145 grams, a 30% weight reduction.
     
  19. DanC

    DanC Active Member

    Thanks for your suggestion. But as far as I know to recalibrate you first need to bind the Controller. See video I posted previously on this thread, and also this link. Unless you're referring to some other method I haven't seen yet?
     
    Jackson likes this.
  20. Loqman Hakim

    Loqman Hakim New Member

    Hey i face this problem also today..

    :( can't even bind syma x8g with remote controller.
     

Share This Page