Syma X5SW-1 transmitter beeping

Discussion in 'Ready to Fly Quads' started by RobA, Dec 26, 2016.

  1. RobA

    RobA New Member

    Hi Everyone.
    I was given my first quadcopter for Christmas. It is a Syma X5SW-1. It flies, but the transmitter keeps making short beeps and the sideways trim control keeps adjusting itself towards full left. (The trim display on the transmitter is initially central and after a few dozen beeps and about 20 seconds it shows full left).

    Consquently, it hasn't been in the air for more than 10 seconds. I haven't crashed it yet.

    Other symptoms are that the signal strength meter on the transmiter is flashing (but with 5 bars). Also then 'H' and 'L' symbols towards the top right of the display flash alternately.

    I've tried a new set of batteries in the transmitter and a freshly charged battery in the quadcopter.

    My guess is that the trim control switch on the transmitter has failed.

    Has this happened to anyone else?
    Is this a common Problem?
    Is it easy to fix?
    Should I return it to the seller since the unit is new and it's never Worked?
    Any thoughts would be gratefully received.
    Rob
     
  2. holtneil

    holtneil Well-Known Member Moderator

    Hi yes sounds like the transmitter is faulty I have had 6 over the last 2 months and never had one like this
     
  3. RobA

    RobA New Member

    Thanks for your comments. I'll try to return it to the seller. If no luck I'll take if apart and have a go at fixing it myself.
     
  4. holtneil

    holtneil Well-Known Member Moderator

    Make them exchange it will be better off to start with one that's right
     

Share This Page