Naza v2 - weird behavior after crach

Discussion in 'General Discussion' started by sowiq, Jul 9, 2018.

  1. sowiq

    sowiq New Member

    Hi Everyone,

    I've got a custom built quadcopter based on s500 frame with Naza v2 as a MC. Everything used to work fine, until a crash I had a few days ago. I had to replace a few broken parts (e.g. props, arms, etc) and replaced a squashed LiPo into a new one (4S, I used to fly on it).

    Before the final wiring, I've calibrated ESCs. Then I connected my Naza v2 and after connecting to my PC, I tried to run a motor tests. But I couldn't.

    Below I listed a few weird behaviors I observed:

    - In Atti mode I can easily arm motors and they slowly spin on idle. But after a couple of seconds, once everything warms up, I'm not able to arm them again. Please see the video I link to.
    - On PMU module, there is a LED, which used to be solid green before. Now it blinks all the time.
    - In the Naza Assistant software I can see "MC OUTPUT: OFF" message. When I try to run motor tests, nothing happens. But Naza connects correctly - I can see RC stick movements, etc.

    Here is my video:

    What could cause the issues above? What should I check?

    Thank you in advance for any help.
     

    Attached Files:

  2. ringolong

    ringolong Well-Known Member

    Its been a while, but I think you can recalibrate the radio with the naza?
     
  3. sowiq

    sowiq New Member

    Hi ringolong,

    thanks for your reply!

    I've done that at the beginning. I've calibrated all ESCs, IMU and the radio. No luck.

    I've also tried to connect ESCs directly to the throttle output on the receiver, to test motors. That way everything works as expected - all motors correctly react on throttle stick movements. So I assume the problem is somewhere with the Naza. But I have no idea how to find out what it is exactly.
     
  4. ringolong

    ringolong Well-Known Member

    Have you tried a hard rest or a refresh of the firmware on the naza? Hopefully its' not a hardware issue.
     
  5. sowiq

    sowiq New Member

    No, I haven't. I didn't even know it's possible to do a hard reset. I'll try do find out of how to do that and will post an update here.

    Thanks!
     

Share This Page