motor remapping/ transmitter wont work

Discussion in 'First Build' started by robert115, Dec 14, 2017.

  1. robert115

    robert115 New Member

    There's a list of problems I've had so I'm including most of them in case they're significant. The parts I'm using are a F3 evo flight computer, a Matek systems PDB, and originally a Racerstar 20A 4 in 1 ESC, but currently I'm using a Lumenier 30A 4 in 1 ESC, a Flysky fs-16x transmitter, and a fs-ia6b receiver.

    The build started out fine, but I couldn't get the motors to spin up once I was done. So I downloaded cleanflight, and was able to test all the motors from cleanflight and they worked fine. After some searching on the internet I found that I didn't have an arming switch, added one, and then the transmitter was able to control them. However, during this motor #4 stopped working. I also had briefly changed the ESC protocol in cleanflight between oneshot42, dshot 150, and dshot 300 while troubleshooting, not really knowing what they did. Upon finding that the motor didn't work, I looked up what they were and found that oneshot wasn't supported, so I assumed I had broken the section of the ESC that corresponded to motor #4. I also switched motors #3 and #4 to make sure it wasn't the motor, and it wasn't.

    Therefore, I bought a new ESC (the Lumenier ESC), installed it on the quadcopter, and the problem persisted. Through a bunch of trial and error, I found out that no signal (as far as I can tell) is coming from pin#4 on the flight controller (all new connections from the ESC to the flight controller due to the swap as well). Not knowing what to do next, I noticed that the flight controller also had pins 5-8, and that cleanflight had an optocopter configuration that matched the quadcopter with the exclusion of motors #1-4 on the octocopter. So I changed the configuration on cleanflight, rewired the signal wires to the flight controller on pins 5-8 in accordance with the new octocopter diagram, assuming that it would still generate signals for #1-4 but they wouldn't be connected to anything, and since the remaining motors were all evenly spaced it would still fly fine. I was wrong, this made all of the motors stop functioning.While looking this up, I found a video about remapping the pin output for a motor. I attempted to make the signal for motor #4 come from pin #5, and then changed the location of that signal wire accordingly. This did allow for all 4 motors to spin up while testing using cleanflight, but the transmitter isn't controlling anything (although it still connects). There was also a note from cleanflight that the pin was assigned to a serial receiver. I'm also using PPM (I've heard i-BUS is better but I don't know how to do that, and at this point I think I've messed around enough). I've included the CLI code below. Following this, I reverted all of the outputs to their original pin locations, and the transmitter still doesn't control anything like it did before (even when it was just the 3 motors). And at this point I have no clue what to do. Any help would be appreciated. Thanks in advance.

    CLI

    # resource
    resource BEEPER 1 C15
    resource MOTOR 1 A00
    resource MOTOR 2 A01
    resource MOTOR 3 A02
    resource MOTOR 4 A03
    resource MOTOR 5 A06
    resource MOTOR 6 A07
    resource MOTOR 7 B00
    resource MOTOR 8 B01
    resource PPM 1 A15
    resource LED_STRIP 1 A08
    resource SERIAL_TX 1 A09
    resource SERIAL_TX 2 A14
    resource SERIAL_TX 3 B10
    resource SERIAL_TX 11 A07
    resource SERIAL_TX 12 B01
    resource SERIAL_RX 1 A10
    resource SERIAL_RX 2 A15
    resource SERIAL_RX 3 B11
    resource SERIAL_RX 11 A06
    resource SERIAL_RX 12 B00
    resource I2C_SCL 1 B06
    resource I2C_SDA 1 B07
    resource LED 1 B08
    resource TRANSPONDER 1 A08
    resource SPI_SCK 1 B03
    resource SPI_SCK 2 B13
    resource SPI_MISO 1 B04
    resource SPI_MISO 2 B14
    resource SPI_MOSI 1 B05
    resource SPI_MOSI 2 B15
    resource ESCSERIAL 1 A15
    resource ADC_BATT 1 A04
    resource ADC_RSSI 1 B02
    resource ADC_CURR 1 A05

    # resource motor 5 none
    Freed

    # resource motor 4 A06

    NOTE: A06 already assigned to SERIAL_RX 11.
    A06 set
     

Share This Page