Mobula7 giving me horrible headaches

Discussion in 'Tiny Whoops & Other Micro Quads' started by ALEC, Dec 15, 2018.

  1. ALEC

    ALEC Member

    Okay I’ve honestly gotten to the point with this quad where I have watched every setup video and guide, I really just need to face time someone and get there help. Is there anyone who would be willing to do that?
     
  2. RENOV8R

    RENOV8R Well-Known Member

    Did you get this worked out yet?
     
  3. ALEC

    ALEC Member

    No I have not
     
  4. RENOV8R

    RENOV8R Well-Known Member

    What seems to be the problem?
     
  5. ALEC

    ALEC Member

    I’m just not sure where I’m going wrong, I’m flying the dsmx dsm2 edition with the dx9 but I can’t get it in the motors turning
     
  6. RENOV8R

    RENOV8R Well-Known Member

  7. ALEC

    ALEC Member

    yes, I’ve spent hours on videos setting this up on beta flight and I’ve copied them exactly so I don’t know where I’ve gone wrong
     
  8. RENOV8R

    RENOV8R Well-Known Member

    Can you go into the Betaflight CLI, type version, then hit enter. Post a screenshot
     
  9. ALEC

    ALEC Member

    Version
     

    Attached Files:

  10. ALEC

    ALEC Member

    I posted the version, waiting a response.
     
  11. RENOV8R

    RENOV8R Well-Known Member

    So that's Betaflight 4.0, don't know why they are loading these with firmware that's still a release candidate. A bit of a pain, but I'd flash it with BF 3.5.3 and go through the configuration again. That's the first thing I did when I got mine and haven't had an issue.
     

Share This Page