Just built a FPV racing drone, trying to figure out how to debug problems

Discussion in 'First Build' started by Brian M, Apr 4, 2018.

  1. Brian M

    Brian M New Member

    Hi,

    I need help debugging my drone to get it working for the first time.

    I just attempted to build my first drone from a recommended build by uavfutures on youtube (part list below). It's all soldered together, but when I turn it on, things aren't going as expected. I'm not sure how to debug the problems without buying a whole new set of parts to see if I burnt anything out. Any advice on a good way to trouble shoot would be super helpful!

    I carefully followed that "uavfutures" channels $99 drone build video and full $200 kit video. I plug the drone in and everything lights up, it beeps, all 4 motors twitch, the VTX shows the channel, the receiver has a solid status light (meaning connected?), but..

    Camera - when I turned everything on and tuned the goggles to match vtx, I could see part of the image clearly in the left 1/5th of the screen and then the horizontal lines got more and more distorted/static-y as you look across to the right. After turning it off and messing with a few things, now it's nothing but complete perfect black (unplugging/plugging camera from powered drone has no effect, but if I unplug drone power, then view goes back to full static. Do I have a bad camera?

    No effect from remote controller - I believe the remote controller is paired as it shows battery status of drone when drone plugged in, and won't turn off until I unplug drone. However, arming it, moving controls around on the remote, etc... no affect on the drone what-so-ever.

    Can't connect to BetaFlight - I've tried installing betaflight on both my pc and mac... both show com port options and when I plug the drone in (no battery on drone itself), the usb cable powers up the flight controller on (lights come on), but no matter what communications port I try (using either computer), the software won't connect.

    I'm wondering if I damaged a board while soldering or something.... is there any way to tell? I've done limited soldering before, but am confident that I don't have an active short. I've heat shrinked all connections and checked continuity of wires/connectors. Any pointers on how to debug my issue(s)?

    Thanks!
    -Brian


    Parts (all from Banggood com):

    · Remote - Flysky FS-i6S
    · ECS - Racerstar RS20Ax4 20A
    · Goggles - Eachine VR-007 Pro
    · PDB - Matek Systems PDB-XT60
    · FC - F3 Flight Controller Acro 6 DOF/Deluxe 10 DOF
    · Camera - Eachine Wizard X220
    · VTX - Eachine VTX03 Super Mini 5.8G 72CH
    · Motors - 4X Racerstar Racing Edition 2205 BR2205 2600KV
    · Battery - ZOP Power 14.8V 1400mAh 65C 4S
     
  2. mozquito1

    mozquito1 Well-Known Member

    Set your Aux channels on your i6
    Channel 5 = Aux1 on SWD, arm switch.
    Channel 6 = Aux2 on SWC, modes switch.
    Which is a 3 position. Switch.

    Then in betaflight modes tab set arm to Aux1 & angle & horizon to Aux2.

    Now presuming you have wired the rx to the right pins your Tx & RX should com to each other. After choosing ibus protocol in configuration tab.
    Send us a picture of how your board is wired.
     
  3. mozquito1

    mozquito1 Well-Known Member

    Sorry I missed the last bit. Did you download all the drivers. I been using omnibus F4 SD lately & they use zadig or the other one I can't remember to use betaflight. Did you check the board was working before any soldering.
    I have stressed enough on here about the old naze32, which is what your board is.
    They where notoriously crap, easy to break & the old 6050 gyro jeez.
    Try all the different combos of rewriting the firmware. & try the boot pin. & check the baud rates match. & try all com ports in the list. I have always used 25000.
    But check you have the VPN drivers aswell.
     
    Gyro Doctor likes this.
  4. Jackson

    Jackson USA member at large

    mozquito1 and Gyro Doctor like this.
  5. Gyro Doctor

    Gyro Doctor Electronics Tech for over 45 years

    :rolleyes: ... Ummm, yeah, what they said ! :p
     
  6. mozquito1

    mozquito1 Well-Known Member

    The obvious ones are easily missed.
     
  7. RENOV8R

    RENOV8R Well-Known Member

    Are you using the latest Betaflight Configurator 10.2.0 from the Github? And the most recent stable firmware release for your flight controller?
     
  8. Brian M

    Brian M New Member

    Wow, can't believe the support. Thanks all!

    Thanks for your pointer on drivers! That took me on a happy path. I thought I had it, but after tweaking got it showing the usb connection, then figured out how to flash so I could actually connect, followed the video’s betaflight configurations and now things are all looking pretty good… dinked around with remote and betaflight for an hour just seeing how it all worked and everything was super responsive… just need to wait for daylight to put blades back on and give it a try. But I feel 95% further along than before.

    That only leaves me with the camera issue. When I first tried, the screen was a clear picture in the left 20% of the screen but then more and more horizontal line distortions/static as you moved your eyes across to the right. After I had played around a few minutes, there was no picture at all, just solid, perfect black when there was power to the vtx. The goggle screen itself seems ok (other goggle indicators like batteries don’t distort), and if I plug/unplug the camera dongle while all is powered up, there’s no change to the black screen. With the cords plugged in, I opened the camera and checked continuity of the signal wire between camera board and vtx, as well as powering it on and validating 5v making it to the camera board.

    The one thing that seemed odd when I first turned it on was that the vtx got *really* hot. Maybe that’s normal, but I had it wrapped a couple times in electrical tape to prevent it from shorting against the frame. So I’m wondering if I either damaged the vtx, or got some sort of bum camera. Thoughts?
     
  9. mozquito1

    mozquito1 Well-Known Member

    Black screen means you got your lens cap on m8. Or wrong channel.
    Have you powered the vtx without an antenna o_O
     
    Jackson likes this.
  10. mozquito1

    mozquito1 Well-Known Member

    I took a brand new foxeer hs1177 out the box only to find its brightness is amazing so much you can't see jack except in dark areas. Changed every setting it alters stuff but it's just to bright & everything is washed out. I forgot to send it back. If I get desperate I may try sort it out again.
     
  11. Brian M

    Brian M New Member

    Heh, I wish it were just the lens cap. :/ And there is an antenna and an obvious difference when the battery is on vs off (perfect black screen vs static)... so I think that's good.

    When I first hooked things up and paired the goggles, I got a "shredded" image... like the attached picture (for illustration purposes only), the left 20% of the image was near perfect, and then individual horizontal lines started looking worse and worse as you moved your eyes right until half way across it was total garbage. I turned things off, figured I'd come back to it, and when I did, I got a completely and perfectly black screen. I don't believe it's the goggles as their OSD elements (brightness, contrast, battery indicator, etc) all look just fine on the screen... and it goes from static to black and back to static when I power on/off the drone. I've tried disconnecting /reconnecting the camera to the vtx while all is powered on, but the black image doesn't even twitch. My FC doesn't have OSD otherwise I'd try seeing if it showed ok.

    I’ve taken off the cover to the camera, and from camera board to vtx board checked the continuity of the signal wire (they’re wired directly to each other) and also verified that with battery, I get the proper 5v on both boards. I’ve got the Eachine Wizard x220 and Eachine VTX03 Super Mini 5.8G 72CH. I did have the vtx wrapped in a couple layers of electrical tape to prevent shorting... maybe I cooked it? Or maybe a bad cam? I'm at the point where I'm guessing I'll need to just buy a new one of each to swap out.

    Does anyone know if i could just take a composite video out from a DVD player and touch it to the vtx transmitter to have it work? Trying to think how to do the last level of debugging to see which thing it is.
     

    Attached Files:

  12. Brian M

    Brian M New Member

    Haha - it is the camera! Took the composite video out from my xbox, hooked up ground and the signal wire to the vtx and viola! I've proved that the goggles and vtx work... and now I can play xbox while racing I guess. :)
     

    Attached Files:

    Gyro Doctor, Dugdog47 and Jackson like this.
  13. Gyro Doctor

    Gyro Doctor Electronics Tech for over 45 years

    :rolleyes: ... Glad you've got it all sorted out ... I was going to suggest providing an alternative video source to the VTX
    to tell which might be faulty, but you already thought of that and congratulations for doing so :)

    Insulate only the VTX side that's against the carbon, you want that puppy to breath as much as it can because they do get warm,
    especially without air flowing over them. ;)
     

Share This Page