horizon hobby glimpse XL / blade 350 QX3

Discussion in 'Getting Started' started by stewarty, Sep 1, 2016.

  1. stewarty

    stewarty Member

    hi everyone...just joined a few minutes ago
    last week I was on holiday in UK and bought a horizon hobby glimpse XL....it was a spur of the moment purchase....I know nothing about quadcopters...stupidity on my part...I should have researched things first but hey ho I didnt
    im back in spain now and have got it charged and ready to go
    ive downloaded and watched a few videos now about getting started
    ive been outdoors and switched transmitter on in smart mode followed by switching on glimpse XL
    they are both on a flat level surface....for about 1 second the led is green then immediately turns to flashing red and beeping constantly...am I being a muppet or could this be a manufacturing fault
    any ideas would be much appreciated...thanks in advance for any feedback
     
  2. RENOV8R

    RENOV8R Well-Known Member

    Refer to page 18 of your manual. Either your battery is not charged properly, or your transmitter isn't bound to your Glimse. Please note that when binding, don't be too close.
     
    stewarty likes this.
  3. stewarty

    stewarty Member

    thanks for your quick reply....I tried binding as per instructions in manual
    when I switch glimpse on it just flashes red and beeps
    I then tried switching on when upside down it flashed red blue and green for a few seconds then back to flashing red and beeping
    I tried the bind procedure then...bind with gps disabled....held bind button in with throttle roll right then powered up transmitter but nothing happened
    still red flashing and beeping....its late here now so I will have another play tomorrow and see how it goes
    thanks so much for your help

    I tried to post a video clip of whats happening with glimpse but couldn't upload it so heres a link to a short clip I put on youtube
     
    Last edited: Sep 2, 2016
  4. RENOV8R

    RENOV8R Well-Known Member

    I don't know what radio you're using, but here's a HH video on initial setup and calibration that might help. This is a not really a toy-grade craft and you'll have some calibrations to do, accelerometer, gps, gyro, etc. Hope this helps get you started.
     
    Last edited: Sep 2, 2016
    stewarty likes this.
  5. stewarty

    stewarty Member


    heres a video clip of what happens when I switch the power on
    don't know if im posting this in the correct part of the forum
    thanks for your help so far
    ive downloaded and watched all video tutorials so I have an idea what to do if the led would go to steady green
    sadly all that happens is it flashes red and wont allow me to use the transmitter radio
     
  6. RENOV8R

    RENOV8R Well-Known Member

    Do you have any way of testing the voltage of your battery? When fully charged, it should be reading 4.2V/Cell
     
    stewarty likes this.
  7. stewarty

    stewarty Member

    hi again...I don't have a voltage tester but shall try to get hold of 1...in the meantime I have messaged blade helis who posted all the video tutorials to see if they may have any ideas...thanks for your help and I will let you know on here if I make any progress
     
  8. RENOV8R

    RENOV8R Well-Known Member

    OK, I just checked your manual and I don't really think you have a problem. Blinking red LED just means you're binded but in Return to Home mode. Make sure the mode switch on the top-left of your transmitter is in the bottom position and wait for the LED to go green. BUT that being said, READ THE DAMN MANUAL. Quote from your original post: "ive been outdoors and switched transmitter on in smart mode followed by switching on glimpse XL" This is wrong. You need to plug the battery into the Glimpse first and do a quick procedure, THEN turn your transmitter on.
     
  9. stewarty

    stewarty Member

    P1000008.JPG

    im sorry...I don't understand...heres a pic of the instructions I followed in my manual...the online manual says the same P1000008.JPG
     
  10. RENOV8R

    RENOV8R Well-Known Member

    1. With the transmitter and quadcopter powered OFF,


    connect the battery to the 350 QX3.

    2. Place the 350 QX3 on a fl at level surface.

    3. Power the 350 QX3 ON and let it initialize. The

    status LED will remain off.

    4. Hold the 350 QX3 upside down until the status LED

    fl ashes blue, indicating it has entered bind mode.

    5. Set the quadcopter back upright.

    6. On your transmitter, ensure the throttle is in the low

    position and the throttle trim is at neutral.

    7. Power ON your transmitter in bind mode according

    to the instructions included with your transmitter.

    8. When the binding process is successful, the

    350 QX3 will emit a quick, 3-beep tone and the LED

    will fl ash either green, purple or red, depending on

    which fl ight mode is selected.

    If the LED is fl ashing red, the 350 QX3 is in Return

    Home mode. Switch to Smart or AP Mode (green

    or purple fl ashing) before attempting to start the

    motors.

    9. Place the quadcopter outdoors in the desired

    starting position in preparation for fl ight.
     
    stewarty likes this.
  11. stewarty

    stewarty Member

    thanks so much for your help and patience
    I have tried this many times but it will not initialise to the l.e.d going blank
    ive left it on for many minutes but it just stays on flashing red
    its late here now so will try again tomorrow
    thanks again for your help...it must be very frustrating for you when someone like me jumps straight in at the deep end without doing any prior research
     
  12. Adetheblade

    Adetheblade New Member

    Hi just a thought, there is a small white plug and socket to the right of the battry compartment, this plug is disconnected and plugged into the usb interface.where you load the firmware . Make sure it is plugged in correctly, if it has been unplugged before it may have bent the tiny pins inside the plug.
     
    Last edited: Sep 5, 2016
    stewarty likes this.
  13. Jackson

    Jackson USA member at large

    [​IMG]
    Am I missing something? Doesn't it say to Power on the TX before the quad?
     
    stewarty likes this.
  14. Adetheblade

    Adetheblade New Member

    Not when your binding it, you need to turn the quad on,turn it upside down until blue light flashes, then turn tx on whilst holding throttle down (not centred but down) whilst also pushing bind button. You need to be at least 4ft away.

    Once it's bound to the tx, then you should "always"turn tx on first.
     
  15. stewarty

    stewarty Member

    thanks for your comment...ive now checked that out and it seems to be fine connection wise
     
  16. stewarty

    stewarty Member

    a brief update to all...still made no progress...ive messaged blade helis on youtube and emailed horizon hobby on technical support about the problem but have not had any feedback about the problem so far...would just like to say thank you to everyone for all your help and input....cheers
     
  17. stewarty

    stewarty Member

    I tried this first because it says in the manual its already preset before boxing for sale...all I got was flashing red light...that's when I tried bind later to see if maybe that would work but just got the same...flashing red light...maybe I will get some feedback in next couple of days from horizon hobby technical support
    many thanks for your input
     
  18. RENOV8R

    RENOV8R Well-Known Member

    So your certain that even with the mode switch on the top left corner of your transmitter in the furthest position (smart mode), you're still getting a flashing red light?
     
    stewarty likes this.
  19. stewarty

    stewarty Member

    sorry for long time to reply...ive been away a lot and when ive been here theres been friends here on holiday
    heres an update on whats happened since my last post...still same problem with flashing red light
    the drone is now back in Scotland where I purchased it
    it appears it is a manufacturing fault which apparently is very rare
    so now it will either be getting repaired or replaced with a new one
    this will take 3 to 4 weeks in the U.K
    once all is rectified it will be delivered to a friend of mine in Scotland who will bring it back to me in spain in December
    so hopefully I will be able to have another attempt to get it up and running
    thanks so much for your help here to all
    in the meantime ive got a loan of an L6052W to have a play with
    once I get the other 1 back I shall post on here to let you know how I get on
    cheers to everybody
     
  20. stewarty

    stewarty Member

    [​IMG]
    finally I have got new replacement drone up and running the other day...its really user friendly for a newbie like me
    thanks again for your help
    heres a link to 1st play with it
     

Share This Page