Holystone F181 Trouble Shooting Issue

Discussion in 'General Discussion' started by Mark No, Jan 5, 2017.

  1. Mark No

    Mark No New Member

    Hi All,

    I'm new to the hobby so bought a Holystone F181 to try it out, based on the 5 out of 5 reviews on Amazon. Unfortunately, though all the rotors work, the darn thing would not throttle up. It just idles. Everything else seems fine. Trouble shooting suggests maybe battery not fully charged, other possible issues - all of which I checked. Contacted Holystone, and they sent another unit for free, and told me to keep the other one for parts - great customer service. But, exact same issue with the new unit. Idles but wont throttle up so wont fly.

    Can anyone suggest a fix for this issue?
     
  2. Jackson

    Jackson USA member at large

    Maybe.

     
  3. Mark No

    Mark No New Member

    Ok, will do. Man does it look like fun.... battery looks right but my control configuration seems a little different from the one in the review. Tried emulating but still cant get either one to throttle up. I'm going touch base with Holystone one more time. Its weird that this is an issue with two different units. Can't help but think I'm screwing something up.....

    I didnt know this was an off brand quadcopter. What is a good brand quadcopter? Many thanks!
     
  4. Wildwelder

    Wildwelder Well-Known Member

    Are you arming the motors correctly? Make sure you read the manual theres very specific steps that need to be taken. It seems like youre quite adept on this, but thought Id throw it out there. BTW did you adjust the trim on the throttle??
     
  5. Jackson

    Jackson USA member at large

    Not an off brand per se. Holystone is not a manufacturer, they just rebadge.

     
  6. Mark No

    Mark No New Member

    I was taking a video of both drones not working to send to Holystone when I accidentally dropped the controller - hard to shoot the video with my phone in one had and the controller in the other. When it hit the ground the controller seemed to reset and then pair, again, with its drone. I turned it on and hit the throttle and it worked. Eureka! I tried dropping the other controller a few times and et voila - the other drone worked too. There must be some secondary step that I was missing. Anyway, I'm happy to drop controllers until I figure it out - it really is a blast. I captured my shock on the video when the drone shot up into the air - think I'll send it to Holystone anyway.

    Thanks for trying to help a newbie out. Much appreciated.
     
    Jackson likes this.
  7. Wildwelder

    Wildwelder Well-Known Member

    The ol Arthur Fonzerelli approach! Sweet
     

Share This Page