Help taking off!

Discussion in 'First Build' started by Elmer Fudd, May 30, 2018.

  1. Elmer Fudd

    Elmer Fudd New Member

    Hi Guys,
    Wondering if you can help a newbie please. I have taken the lunge and am building my first quadcopter. It is on a 250mm frame with a Naze32 for flight controller. My Motors are Eachine MN2205 2300kv, ESC is Eachine 4 in 1 30A. I am using 5045 propellers.

    Everything seemed fine after initial construction but on take off the quadcopter flipped. I found one of the motors going wrong direction. D'oh! Anyway two news propeller later I am still having problems with the quadcopter flipping. Problem now I think it's one of the motors is running slower than others. It seems to have to over come some static friction to get moving. In motor tabs of Cleanflight other motors start moving at 1145 while this motor needs to be over 1250 to start moving. I tried to calibrated a few times by putting sliders at max and then plugging in battery but still have the issue. I am unable to calibrate ESC using blheli software as Naze32 will not allow passthrough.

    A few questions really :
    1. Are my suspensions correct with regard to motor sticking and this is the reason the quadcopter will not fly?
    2. How can I calibrate the ESC? Or is what I have tried correct?
    3. Is there something I am missing?

    Thanks in advance for the help.
    Rob
     
  2. RENOV8R

    RENOV8R Well-Known Member

    Yes, unless you have something physically binding inside the motor, it sounds like your ESCs aren't calibrated properly. you say you've put the sliders to max and plugged in the batt, but that's only half the process.

    With quad unplugged put the sliders to max
    Plug in the batt, you'll hear dah dah dah....dee dee (it's now calibrated full throttle)
    move sliders down to zero, you'll hear dah dah dah....dee (it's calibrated zero throttle)

    Hopefully you're ESCs are now calibrated and your motors start up at the same time.
    If not, let us know as there are a few other factors that can cause a quad to flip on takeoff
     
  3. mozquito1

    mozquito1 Well-Known Member

    Anything but a naze32. There are other f3 fcb's just as cheap with better gyro.
    Don't buy anything with the mpu6050.
    Get a cheap servo tester to do your esc's because no pass through. Then once on the built quad you are OK. You can calibrate in motors tab, if not using dshot.
     
  4. Elmer Fudd

    Elmer Fudd New Member

    Thanks for the response guys. Yes the ESC seems to be dshot. I am not hearing the beeps when I go to calibrate but looking at the settings it seems that the Naze32 will not allow me assign the ESC as dshot and keeps switching back to Oneshot. I will try to force to dshot later using CLI but by sound of it naze32 may be not compatible with the ESC.
     
  5. mozquito1

    mozquito1 Well-Known Member

    There wasn't even blheli when those boards first came out. I know they run one shot.
    With the the most recent update I have no clue what they can run.
    Have not used a naze for about 2 years now. But yes multi or dshot is probably non compatible. Trust me dont buy a naze ever again. SPF3 are OK & cheap enough to replace if need be.
    Omnibus F3 SD are a decent option for newbs(sorry) but cheap with all you need. Good layout.
    Anything with the mpu6000 gyro.
    They advertise the naze as upgraded from F1 to F3 but they have the same useless gyro.
     
  6. miketuite

    miketuite Member

    Dumb newbie question, but I'm having the same problem. What are you talking about when you say "sliders?"

    Thanks for your help,

    Mike
     
  7. Elmer Fudd

    Elmer Fudd New Member

    Hey Mike
    There are motor sliders in Cleanflight so you can check the motors are operating correctly. I think the problem I was having is compatibility issue between ESC and FC.

    Hope this helps.
    Rob
     
  8. mozquito1

    mozquito1 Well-Known Member

    Like a digital volume nob slider thing like on an old hifi..except its on screen.
     
  9. miketuite

    miketuite Member

    Got it! Thanks, guys.

    Mike
     

Share This Page