1. NOTICE: We're currently noticing some EMAIL DELIVERY ISSUES to Outlook and Hotmail email addresses. If you're a new member and don't receive your confirmation email, feel free to reach out to us via the contact link at the bottom right of the page.
    Dismiss Notice

Firmware install problems

Discussion in 'Newb Guides' started by Rotor69, Jul 30, 2016.

  1. Rotor69

    Rotor69 Active Member

    need help on installing firmware to my quad , eachine 250 racer
     
  2. Quadcopter102

    Quadcopter102 Well-Known Member

    Firmware for what? your FC? Eachine tend to use a customised version CC3D. Do you have OpenPilot, or LibrePilot on your computer?

    If you have Openpilot.... its dead basically and no support, LibrePilot is a rework of the Open Source code and updated - https://librepilot.atlassian.net/wiki/display/LPDOC/Downloads

    Beware - if you blindly run the setup in LP your will overwrite all your settings. I suggest you export the UAV settings. personally being brain dead - I prefer to also screen shot all relevant settings like the PIDS - look at the "configuration" tab at the bottom of the page and then the "stabilization" icon - it will show the pid settings. Write or screen shot them and if you have issues when converting from OP to LP - and importing the UAF file - you have another list of the settings.

    I suggest you use the download link to look at the main menu on the left - which hold links to what is basically a LP manual and read it all a couple of times before setting out on any changes.
     
    GJH105775 likes this.
  3. Rotor69

    Rotor69 Active Member

    Yes for my Eachine, thanks for the response yes open pilot is no more I do have libre pilot on my laptop .

    I flew the quad copter a few times , no problems , the last time I flew it I crashed it , right rear motor has no rotation nor does it have pre flight sequence movement once battery is plugged in , I tried replacing motor and ESC but to no avail.

    Also , camera signal gone and front LED lights not working , the other three motors work and respond to transmitter , I was hoping that if I plugged it in to libre pilot I could see where the problem is without tearing the whole thing apart , and someone told me I had to every time I change out a ESC
     
  4. Rotor69

    Rotor69 Active Member

    A
    also , plugged my Eachine in to laptop and my pc or and libre pilot does not seeit ?
     
  5. Quadcopter102

    Quadcopter102 Well-Known Member

    How do you mean does not see it?? Do you see "coptercontrol" in the connections tab at the bottom right of the LP screen? If not then your quad - is not connected.
     
  6. Rotor69

    Rotor69 Active Member

    I see nothing , in the set up wizard :
    " board identification" it does not recognize my Eachine it is blank
     
  7. Quadcopter102

    Quadcopter102 Well-Known Member

    When you open LP and have a USB cable connected from your computert to your flight control - do you see " "USB:CopterControl" at the bottom right of page "Connections".
    If the answer is NO - then you are not connected to LibrePilot and LP will not "see" your FC data.
     
  8. Rotor69

    Rotor69 Active Member

    yes I did finally get it connected , I ran the motors through the program , all motors spun except the right rear , it seems that something got damaged in the crash ! In the program , it doesn't tell me that there is a non functioning component in the quad it self , I guess I will have to order a new bottom board for the quad ?
     
  9. Quadcopter102

    Quadcopter102 Well-Known Member

    You can try moving a "Good" motor to the right rear and testing if it works OK - put the bad motor in place and check again...don't worry about rotation direction - its testing the motors. Also... if you have a mutlimeter - you can check the circuit connections for continuity.

    Is there any actual damage to the board that could indicate a break in the circuit?

    Did you solder the various Battery/PDB/ ESC /motor connections or solder male/female bullett connectors - which ever -- have you checked all connection are still valid?
    Have you checked the connections from ESC to flight controller?

    After a crash and having any malfuction, unless its obvious what the problems is and make a replacement/repair - then you really have to check everything. And dont forget to reset the gyro's and ESCs.
     
  10. Rotor69

    Rotor69 Active Member

    ok , I will try the motor exchange first with the old ESC and see if this works if not I will try the ESC and motor in the working locations, I dd check with multi meter only for voltage not continuity , the voltage was good at the main solder point before the ESC at all 4 locations,.

    no, no visible damage at all , which is racking my brain, also the two LED lights at the frnt of the copter are not functioning and neither was the camera , I did put another 5.8 GHz antenna on and that solved the camera issue.

    I soldered the connections as it was when delivered to me , I did not use any extra components such as quick connects or anything like that , how can I check the ESC to flight controller ?

    please help on resseting the gyros and ESc's
     
  11. Quadcopter102

    Quadcopter102 Well-Known Member


    OK, connect your quad to LP and use the "Configuration tab at the bottom of the page to open the options - Open the Attitude tab (Spirit Level icon) fourth from bottom icon.

    Make sure your quad is as level as you can and hit the LEVEL button.

    ESC Calibration - use this link to read the article - https://librepilot.atlassian.net/wiki/display/LPDOC/ESC+Calibration

    Basically it means going to the motors page - no props on quad - link all the motors and pull the slider to FULL. Plug in a battery and immediately you hear the ESC beep, pull the sliders to ZERO.
    You can then unlink the motors and using the test outputs tab at the bottom...slide each motor to its lowest starting point - I find that if all was OK... every motor start at the same point.
    OR - you can go through the setup procedure but skip everything till you the individual motor setip and press start and set the lowest spin point... again - I find they all start at the same point if the ESC are calibrated.

    I have to add - I use Emax SimonK ESCs - which I have already programmed each using the Emax programming gizmo, so I dont know how other ESCs react.
     
  12. Rotor69

    Rotor69 Active Member

    standby, I will try this and get back to you once I have done this, thank you very much , I will let you know the results once I complete these tasks!! again thank you.
     
  13. Rotor69

    Rotor69 Active Member

    When I plug my quad into the program it says : GCS and firmware versions of the UAV objects set do not match which can cause configuration problems .

    Do I ignore this and proceed ?
     
  14. Rotor69

    Rotor69 Active Member

    So , I went ahead and went into the ststem regardless of warning , I'm to deep in this anyway so if all else fails I will just get another one lol .

    Ok , so I went in and clicked on lower right button flight data , I moved my quad by hand and the quad moved in the direction I was , then there is a screen to the left of the VR quad screen and it has buttons , some green which is good and some brown , now , I clicked on the brown ones and the same message popped up :

    RC input : WARNING
    One of the following may be present :

    System is in fail safe mode.
    Failed to update one or more of the accessory channels.
     
  15. Rotor69

    Rotor69 Active Member

    YOU !!!!! ok ! I did what you said , and it worked, thank you for teaching me what I need to know! man I feel great right now! and then now after all that my transmitter is not binding, any suggestions?
     
  16. Quadcopter102

    Quadcopter102 Well-Known Member

    It sounds like you CC3D was configured on OpenPilot firmware. The warning you saw were to advise you would change your firmware. So now it seems its on LibprePilot firmware - which is more up to date than OpenPilot which will never be updated again.
    You will almost certainly have lost the PID and other configuration that was on your flight controller and you will now have either whatever you have tuned into the FC or whatever applied to your 250 quad from the options. From Memory - there is only one 250 setup on a 3s lipo - which I presume is what you have.

    Transmitter and RX binding. I am guessing you have the flysky iA6 TX and a 6 or 8 channel RX. I am not sure of the binding process with that set up - BUT - I have the Turnigy i10 and use a number of the FlySky iA6 A RX. Binding them to my TX can be a frustrating event!
    I run the binding process... the red light is steady on restart - indicting a successful bind. But the TX does not do anything to the quad!
    I have to repeat the process time after time. What I do now is run the bind process - see a staedy red light in the RX... turn it off ( unplug battery) also now close the radio. then start radio - connect battery - try to start the motors. It works about 7 out of 10 times! last week I had this problem with a new RX.... in the end i gave up and went to regain my life with a wife and TV! Next morning came in to my "shack" - started the radio - plugged in a battery - fires it up and the motors started!

    Word of advice: one of the most common errors with LibrePilot is - you have to remember to set the arming sequence and safe before disconnecting.
    In LP, usal, bottom tabs - configuration - look for teh rdio icon and open it... top tabs - Arming Settings - the drop down menu will offer you choices - yaw right may be better suited - but you make a choice - save it and start the binding process.

    I also suggest that your life will be less fraught and your flying much more thrilling.... if you spend some time going through the LibrePilot Manual online - if you look at some of the photo sequences which appear as slide shows - they can be downloaded as a PDF and easier to get at!

    https://librepilot.atlassian.net/wiki/display/LPDOC/User+Manual

    https://librepilot.atlassian.net/wiki/display/LPDOC/Multirotor+Wizard
    Look at the bottom left of the slide show panel - a down pointing arrow underlined - click that to download a PDF which shows all the stages in the setup. Look at other similar pages and look for the download indicators...life gets easier!

    Also ......
    you have lost the presets Eachine use - so your PIDS may be suspect so be careful on start up. If you have problems - it may be that one of teh guys who has teh same eachine - can advise you on the PIDs etc,.


    Hope that helps...
     
  17. Rotor69

    Rotor69 Active Member

    It has my friend , I will follow and advise , if or if it doesn't work , thank you for all your help ! Really ! It's been a pleasure , I will keep you updated on what happens , thank you!
     
  18. Quadcopter102

    Quadcopter102 Well-Known Member

    Its really thanks to all the guys on this great forum who helped me over the last year or so...... without them I would have given up and started knitting classes ;)
     
  19. Rotor69

    Rotor69 Active Member

    Lmao !!!! No doubt , my wife told me to get a hobby so I did and she said I didn't know it was so expensive or I would have been knitting too! That's awesome , like I said , you have helped in a great measure my friend ! I will always be greatful , stay tuned , I will let you know what I come with as far as solutions !
     
  20. Rotor69

    Rotor69 Active Member

    ok , so watched a lot of videos............................ found out how to bind the quad receiver to the transmitter ......................... transmitter shows battery life for the RX but I have no controls working .....................UUUUUUUUUUUUUUUUGGGGGGGGGGGGGGGGGGGHHHHHHHHHHHHHHHHHHH
     

Share This Page