Eachine Wizard x220 YAW problems

Discussion in 'Mini Quads & Racing' started by Sciuruz, Sep 24, 2017.

  1. Sciuruz

    Sciuruz Member

    Hi

    I have been playing around with my x220 and I realy like this little thing and its quite good for the price.
    But I have one major problem The YAW won't adjust to 1500, when I try to adjust it it goes aither to 1499 og 1501 not 1500. I have tried in adjusting in betaflight and on the remote but nothing solves the problem (subtrim and Endpoint).
    Quite anoying to re adjust the YAW all the time during flight.
    It looks like it is the remote itself that won't go to center. Is there any way to fix this ?


    Ihave the FlySky FS-i6 controller
    Betaflight 3.2 Newest version

    Se pictures for more info
     

    Attached Files:

  2. RENOV8R

    RENOV8R Well-Known Member

    Try setting your RC deadband to 1, should help. Also see no mention of calibrating your accelerometer. Have you done this?
     
    Gyro Doctor likes this.
  3. Sciuruz

    Sciuruz Member

    When you set the RC deadband, what exactly does it do? Should i also do something about the Yaw deadband?
    I havent been into the Deadbands so will I se the changes right away ore do I have to power up the drone an fly it to se the actual changes?
    The accelerometer is calibrated an working fine.
     
  4. RENOV8R

    RENOV8R Well-Known Member

    Go into your receiver tab and if your problem is related to your flight controller and not mechanical (weak motor, COG) you'll see the virtual image slowly rotating on it's yaw axis. Just tweak the yaw deadband up or down until the quad stabilizes. Also make sure your mid channel is at 1500.
     
    Sciuruz and Gyro Doctor like this.
  5. Gyro Doctor

    Gyro Doctor Electronics Tech for over 45 years

    The "DeadBand" setting tells your radio to ignore small movements of the sticks around the midpoints.
    The larger the setting the more the stick has to be moved away from center before the radio will consider it to be a valid command.
    With the deadband adjusted, put the quad in a hover and just adjust the trim until yaw is stable and there's no rotation then you should be good to go. ;)
     
    Sciuruz likes this.
  6. Sciuruz

    Sciuruz Member

    Thank you guys :)
    I will try this as fast as I can
    I will get back to the tread to update if it worked or not ;)
     
  7. Sciuruz

    Sciuruz Member

    Thanks once again :). That solved the problems with the YAW. So now I just have to fine tune the rest of the settings and that is quitemore interesting when you don't have to focus on turning your quad al the time ;)
     
    Gyro Doctor likes this.
  8. Gyro Doctor

    Gyro Doctor Electronics Tech for over 45 years

    ... Glad to hear you've got it working ! :)
     

Share This Page