DYS VTX not getting power

Discussion in 'First Build' started by woodystyle777, Jan 10, 2018.

  1. woodystyle777

    woodystyle777 Member

    Hi im installing a new DYS VTX on my Tyrant S. I just hooked up the 3 coords (1. 5v in 2. GND 3. AV in) to the cables coming from the FC. This is the same way that both the tyrant s original VTX and a TBS unify were plugged in and worked. When I turned on power after plugging up this DYS, I got no power to it. The rest of the quad had power just fine. This DYS MI200 also has a 5v out and GND with it that I was told you could send to the camera if you wanted. I did not hook these up as the camera already gets power from the FC. Any thoughts?

    p.s. What does VCC stand for on a FC?
     
  2. mozquito1

    mozquito1 Well-Known Member

    Voltage current collector... Power in +
    Should be super easy power & ground.
    & camera signal in with 5v to power the cam. Don't connect through the fcb.
     
  3. RENOV8R

    RENOV8R Well-Known Member

    Sounds like it's a dud. If you read the reviews, this is happening to a LOT of people.
     
  4. woodystyle777

    woodystyle777 Member

    Thanks for the replies guys. It may be a dud I have seen some of these reviews. But just to give it one more shot I want to hook it up properly.

    The camera is already getting power, grd, and signal from a JT plug on the FC. For the VTX should I just flip the board and solder to 5V, GRD, and video?
     
  5. mozquito1

    mozquito1 Well-Known Member

    You should have vtx turned on in configuration tab. If going through the fcb. If your supplying just 5v & no sign of life off it then it's bust. How long have you had it. You should check everything that comes asap so you can send back if need be or buy two. Eachine vtx stuff is OK for the price.
     
    Last edited: Jan 11, 2018

Share This Page