Direction problem on x5sc

Discussion in 'Ready to Fly Quads' started by Robert Bray, Oct 30, 2016.

  1. Robert Bray

    Robert Bray Member

    have a problem with my x5sc, it will fly forward very fast but when I pull back on the stick its coming back to me very slowly, I have to have the trim all way back to stop it flying forward on its own. I have done the calibration but this makes no difference. its only a week old as well. should it fly faster forward than back ?
     
  2. RENOV8R

    RENOV8R Well-Known Member

    Technically, it should go backwards about the same speed as forwards but if you.ve got the trim maxed out to hold it then something's not quite right. You mentioned you've done a calibration, but read the manual carefully be cause it sure sounds like that's your problem. And make sure your quad is perfectly level. I actually use a spirit level and shims under the landing gear when I calibrate as 2 or 3 degrees off level is difficult to see, but can cause quite a bit of drift
     
  3. Robert Bray

    Robert Bray Member

    Yeah I've tried on a very level surface and it's still the same. It was my first drone so inevitably it has taken quite a few knocks! It doesn't have any major damage to it though. I've ordered new gears and motors and I'll swap them out to see if it helps, but starting to think it may be software located or at least a damaged receiver board...?
     
  4. jake8131

    jake8131 Active Member

    Recalibrate the gyros.
     
  5. Gabriel Yee

    Gabriel Yee Well-Known Member

    Try re calibrating and resetting the drone...if not convince the wife it's broken and get a new better drone :D
     
  6. jake8131

    jake8131 Active Member

    There is two calibration procedures. The one when you move both sticks to the lower right. Now do it again but move the sticks to the lower left!!
     
  7. Robert Bray

    Robert Bray Member

    Ok so new motors and gears arrived also I changed out the suspect motor and gear first! Worked a treat for 2 minutes. Placed landing gears and screws back in. Fired it up again and it's the same problem! What the hell! Swapped out rest of motors and still the same! Help!!!
     
  8. Gabriel Yee

    Gabriel Yee Well-Known Member

    You need to check the trim of the controller. Also check the wiring (maybe a loose wire?) finally just fly without the landing gears if that works
     
  9. Robert Bray

    Robert Bray Member

    And by same problem I mean it won't lift off. I sorted the backwards forwards issue during my 2 minute flight! Thanks for that too. Now it won't lift. Bodes correct and spinning correct directions
     
  10. Gabriel Yee

    Gabriel Yee Well-Known Member

    Then the rotors are installed incorrectly
     
  11. Robert Bray

    Robert Bray Member

    Hi they are all spinning correct directions and blades are installed as per the pictures. I don't understand it. It worked while secured temporarily with tape after I changed the motors but then I removed tapes, put screws back in and turned back on and now it won't fly.
     

Share This Page