Bugs 5w GPS Query

Discussion in 'Getting Started' started by Azurian, Feb 4, 2019.

  1. Azurian

    Azurian Member

    I recently bought a Bugs 5w - my first drone and am so far very pleased with it. However I cannot get it to follow me, circle or follow a track because I keep getting a message saying the GPS signal is too weak.

    The controller shows satellites in the high teens or twenties and the return to home function works fine. The Bugs Go app on my phone shows video fine but in the top bar next to the GPS symbol it either shows an x or 0. The GPS in my phone is turned on and other apps using it are fine.

    I am not sure if this app should be showing the number of satellites the phone GPS is using or if it should be getting them from the drone. Or am I doing something simple wrong - beginning to wonder if the fault is in the drone, app or phone. Hope somebody can hep.
     
  2. RENOV8R

    RENOV8R Well-Known Member

    Do you have Bluetooth turned off on your phone? This can cause issues
     
  3. Azurian

    Azurian Member

    Thanks for the suggestion. Tried turning Bluetooth on but no joy. Since my first post I uninstalled the Bugs Go app and reinstalled but while in Google Play Store I took a look at the reviews and it looks like a new version of the app was put out in December and quite a lot of other people have the same problem particularly with newer versions of Android.

    I guess they will fix it some time - meanwhile I have a drone that takes good pictures and videos is stable and easy even for me to fly pus it comes back automatically just with a touch on the RTH button even when I get disorientated.

    Frustrating nevertheless though as I bought a new Motorola Moto G5S Plus as this drone needs a phone with dual band wifi. It does everything it should with my son's I Pad but of course the app is a different version +!**?#*?
     
  4. tOpi

    tOpi Member

    I had same issue, I have motorola g6. looks like the problem is in the android app, in your android phone make sure that gps is allowed on bugs go app, turn on wifi and open Bugs go, open the maps and click on the blue dot, it should connect in few seconds, make sure that you are outside to catch gps signal. Bugs go cannot connect to gps via mobile data, but can just from wifi :/
     
  5. tOpi

    tOpi Member

    But i think once you connect to the maps via wifi you should be able to use it with mobile data. I will test this later. I seen all Youtubers using mobile data as they are in the middle of nowhere. Or if still not working there is also option with second mobile phone make wifi hotstop and with your phone connect it outside.... can be able to get gps signal.

    Actually i has JJRC X5 Epik but they are same, I am using Bugs go app
     
    Last edited: Feb 28, 2019
  6. Azurian

    Azurian Member

    Hi tOpi,

    Just wondering what version of Android your phone runs? Mine is 8.1 but I see from the feedback on Google Play Store other people seem to have had similar problem with Android 8 or higher ever since an update of Bugs Go was issued on December 21st but it works OK on older versions.

    Thought I had it sorted yesterday with drone on window sill. But outside today yes I get the video OK but either get a Chinese map or Google earth at scale showing whole UK. No satellites showing on the app.
     
  7. tOpi

    tOpi Member

    Maybe you are right, I am using on my phone android 8, it doesnt work. But on my wife phone android 6 it working all good without problems. And by the way there is a update on Bugs Go App from 6.3.2019, but still not working!!!! The gps in the app cannot connect still ...
     
  8. Azurian

    Azurian Member

    Yes I got the new app as well - version 5.5. I have found out on Youtube I can get the map by having the phone connected to my home wifi and keeping the app live then going outside where the drone can get a GPS signal and connecting the phone to it. Can then toggle back and fore between camera view and map. Still no satellites on phone though and it seems to give a funny reading for drone battery and nothing for controller battery. Controller working fine.

    I only bought this phone because of the Bugs 5 W and I think when it came it had android 7.1 but I followed on screen prompts to download updates so it is now 8.1. I am wondering if I hit the "factory reset" and it goes back to 7.1 if it would be a fix. Not sure if I want to do this unless somebody can tell me it will be a fix as it will wipe other apps and stuff. My son says never update - stick to the original software because you know it works with the hardware but he has had some bad experiences with Apple.

    On Google Play some people also say it works OK with Android 6
     

Share This Page