arris x-speed 250b motor not working

Discussion in 'RTF Modification & Repair' started by Remkye Henriquez, Jan 5, 2017.

  1. Remkye Henriquez

    Remkye Henriquez New Member

    Having issues with my arris, Is my first drone and after a couple of flights the rear motor stopped working, tried looking info on how to check current using my multimeter but couldn't figure out how.if anyone could point me in the right direction or tell me what to replace, idk how to tune them. Here is the link of the video I posted on youtube.

     
  2. Jackson

    Jackson USA member at large

    Go back to where the ESC is soldered to the PDB. Put your meter probes on the +/- connections and see if you are getting a voltage reading there.
     
  3. Remkye Henriquez

    Remkye Henriquez New Member

    tried checking with my multimeter set to a/c but i might be using the wrong dial since I didn't get any reading from either the bad one or the good ones, sorry I'm such a noob at this.contacted hobby wing and they told me to update the esc and that did not work either, so now they told me to remove a good motor and put it where the bad one is to check if is the esc or the motor the one bad, but before I do that I'd like to check with the multimeter like you told me, I am using a performance tool multimeter
     
  4. Jackson

    Jackson USA member at large

    It needs to be on DC and a low range.
     
  5. Remkye Henriquez

    Remkye Henriquez New Member

    [​IMG]
    thank you so much jackson, just a couple more questions, does battery needs to be plugged in? And from where do I measure?
    from where the 3 small cables are by the controller? Or from the 2 thicker ones?
     
    Last edited: Jan 5, 2017
  6. Jackson

    Jackson USA member at large

    Yea take off your props and plug it in. The thicker, black is -, and red is +. You may have to work the throttle too.
     

Share This Page