I did it!!!!

Discussion in 'Newb Guides' started by dragger201, Nov 23, 2017.

  1. dragger201

    dragger201 If it ain't broke, don't fix it??? You kidding?

    No not that!!!

    Anyway, got one of these..........
    https://www.ebay.com/itm/QAV250-Qua...e=STRK:MEBIDX:IT&_trksid=p2060353.m2749.l2649
    to build my 250mm quad. What a nightmare trying to figure out why it wouldn't connect. First, it's not got the MultiWii firmware, it actually had Cleanflight 1.11.0. But just could not connect with any of the configurators. I had originally installed this......."CP210x_Windows_Drivers" and thought I was good. But no matter how many times I ran Zadig and ImpulseRC and several other apps, just could not get the FC to talk to my PC. I downloaded and installed the "STM32" drivers...........again. Then in recovering old ground I discovered.........."https://www.silabs.com/documents/public/software/CP210x_Windows_Drivers_with_Serial_Enumeration.zip"........but the installer didn't work so I went to Device Manager, did an "Update Drivers" and manual selected the folder with the "Serial Enumeration" and VOILA..........FC talks to PC. So flashed the Betaflight firmware but when setting FC up, notice my baro was gone. But had enough for one day and just reflashed FC with Cleanflight 1.14.0. When I can find something definite on what the latest firmware I can flash on Rev 5, I'll reflash with the latest. Or maybe even see about using Betaflight if I can get my baro sensor to work..............

    [​IMG]
     
  2. Rick M

    Rick M Absent-minded professor

    I gotta hand it to you, you're persistent! I'd definitely recommend flashing with Betaflight. And that had to be a lot of soldering!
     
    dragger201 likes this.
  3. dragger201

    dragger201 If it ain't broke, don't fix it??? You kidding?

    Naw, Rick........no soldering involved............thankfully............
    And yeah, once I figure out turning on the baro and compass I'll definitely be flashing Betaflight................
     
  4. RENOV8R

    RENOV8R Well-Known Member

    You'll be able to enable the barometer in the Betaflight configurator
     
  5. dragger201

    dragger201 If it ain't broke, don't fix it??? You kidding?

    Yeah, I found out how to do it about half an hour ago, but 4 hours straight this morning........I'm taking the rest of the day off...........
     
    Rick M likes this.
  6. RENOV8R

    RENOV8R Well-Known Member

    Hahaha information overload, brain shutting down......................
     
    dragger201 likes this.
  7. dragger201

    dragger201 If it ain't broke, don't fix it??? You kidding?

    Exactly....................
     
  8. ArmyVet

    ArmyVet Well-Known Member

    Not sure why I found this appropriate............But resistance is futile:eek:



    [​IMG]
     
    dragger201 likes this.
  9. BsNQuads

    BsNQuads Member

    hi guys I am having the issue that I cant connect my stm32f407 to any configurator like Betaflight, Cleanfligh and evern Droning! I've installed all the drives but no luck!
     
  10. RENOV8R

    RENOV8R Well-Known Member

  11. BsNQuads

    BsNQuads Member

    Hi RENOV8R, thanks for the prompt response. I just tried impulserc right now and this is the message I get. "An error occurred while entering bootloader! Unexpected number of devices detected." I only have the quad connected. I've been at it for weeks already and cant connect to this dam thing.
     
  12. RENOV8R

    RENOV8R Well-Known Member

    Did you have your quad connected to your computer and Betaflight opened up first?
     
  13. BsNQuads

    BsNQuads Member

    This was made by Aeroquad back in 08. I have not done a firmware update in a long time as this is the first time trying to get this quad up and running. its the Typhoon afr
     
  14. BsNQuads

    BsNQuads Member

    Yes, its connected and Betaflight running. Made an improvement, new error: "Access to the port 'COM3' is denied"
     

Share This Page