First full build F3 FC frustration

Discussion in 'Build & Tune' started by FPVwannaB, Jan 5, 2018.

  1. FPVwannaB

    FPVwannaB Active Member

    Got two of these: https://www.gearbest.com/flight-controller/pp_638475.html


    F3 ACRO 6DOF Flight Controllers. One has its boot pins bridged one does not. Can't seem to flash BF or even Cleanflight. It says in CF it needs an update but when I go to choose the version I pick SPRACINGF3 and the latest version but I either get a bootloader error (unbridged) or a communication error (bridged boot pins). I am not sure what I am doing wrong, I am using the chrome apps on my macbook and they always work. Help? Obi wan? Anyone?

    Sorry if this is a noob question but I have been searching all over and doing what should work.
     
  2. FPVwannaB

    FPVwannaB Active Member

    getting this in BF
     

    Attached Files:

  3. FPVwannaB

    FPVwannaB Active Member

    STM32 Communication failed, wrong response, expected: 121 (0x79) received: 31 (0x1f)
     
  4. RENOV8R

    RENOV8R Well-Known Member

    Couple things that may help. As it's an SPR F3, on the setup screen enable "check manual baud rate" and set baudrate to 115200.

    Have you got the corresct CP210 or STM32 drivers installed

    Run the ImpulseRC Driver Fixer (don't know if this'll help as I don't think the SPR is a VCP board)
     
  5. FPVwannaB

    FPVwannaB Active Member

    MacBook pro so I have some limitations. I can try that baud rate. I have the latest CP210 (maybe a reboot after install might help as I did reinstall them.
     
  6. mozquito1

    mozquito1 Well-Known Member

    He must be on the correct baud rate as he accessing firmware flasher.
    Did the board work when you first got it or did you put it in the quad then try it.
    I set my board up & pids before it goes in.
    And give it a conformal coating. The pins only need to bridge for a second on switch on. Don't leave it in. Try each combination of board reset. Usually spf3 are cleanflight boards. Maybe try cleanflight. With it being a clone it maybe locked to CF. I got a BF F3 & vendors description says CF or BF but it's only Betaflight & I can't even update it.
    But it works.
     
  7. FPVwannaB

    FPVwannaB Active Member

    Cleanflight is a no go, and the boards are fresh and uninstalled, flashing first
     
  8. mozquito1

    mozquito1 Well-Known Member

    Have you got the standalone betaflight 10.0 yet off github. You won't or may not be able to use chrome apps soon. If not already.
     
  9. RENOV8R

    RENOV8R Well-Known Member

    9 dollar FC, probably only a 50% chance of getting one that works.
     
  10. mozquito1

    mozquito1 Well-Known Member

    Better than a naze or ccd3.
    This is one I just replaced with an F4.
    IMG_20180105_174508544_HDR-768x1367.jpg
    IMG_20180105_174531254_HDR-768x1367.jpg
    19 months old, survived countless crashes, been in 3 frames & about 80hrs flight time. Not bad for a £20 board that still works. & I got another to boot.
     
  11. FPVwannaB

    FPVwannaB Active Member

    Yea, I have 2 of them, both have the same problem, guessing we are dealing with a driver problem here
     
  12. FPVwannaB

    FPVwannaB Active Member

    HAH! I came to work and used a PC with "STM8 Flash loader demonstrator". I was able to flash the thing and give it the proper drivers so I could flash Betaflight. One board was bad too I think. Albert Kim has a video on how to unbrick so maybe...
     

Share This Page