Eachine Flyingfrog q90, Devo 7e Connection Problem, Need help

Discussion in 'Introductions' started by Maustrian, Apr 21, 2018.

  1. Maustrian

    Maustrian New Member

    I´ve recently bought the Eachine Flyingfrog q90, with the DSM2 receiver, and because I already have got the Devo 7e transmitter, flashed with the Deviation FW: devo7e - v5.0.0, I wanted to use it to fly the quad.

    But the Problem is:
    When I try to bind it with DSMX the LED on the receiver board first rapidly flashes and then stays on, just like the manual describes it, but the motors won´t spin.

    I connected the quad to my computer and looked into Betaflight, in the receiver tab nothing moves, so I assume there is no connection?
    I checked in the configuration the receiver settings, but it was also set to the right receiving mode: "Serial receiver(SPEKSAT, SBUS, SUMD)" and serial receiver: "SBUS".

    I´m aware that this quad also has an FPV system but I want to get it flying first.
    I´m pretty new to this so don´t really know what to do next, would appreciate any help, thanks!

    UPDATE:

    So still my first post I´ve tried some things so I wanted to give you an update:

    I´ve still set the receiver mode to "Serial receiver(SPEKSAT, SBUS, SUMD)" but switched the serial reciver setting to the options "SBUS, "Spektrum1024" and "Spektrum2048" and tried them with the transmitter protocols "DSM2" and "DSMX".
    I´ve tried switching the serial Port in Betaflight to "UART2" / "UART3", same result with the different UARTs.
    I´ve even tried to resolder the UART cable from the reciver to the other UART port like shown in this video:

    The DSM2 receiver is the CYPRESS CYRF6936.
     
    Last edited: Apr 24, 2018

Share This Page